aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-06-23 14:35:16 +0800
committerrafan <rafan@FreeBSD.org>2007-06-23 14:35:16 +0800
commit3bda34fefd54b4ff7a740b347c7931ce591fa28b (patch)
treeaa12edcacdd6efe1abada9959f47576cc2e5abb1 /security
parent62b8e72b582c1a9b8b553aa68a71a0023af7350c (diff)
downloadfreebsd-ports-gnome-3bda34fefd54b4ff7a740b347c7931ce591fa28b.tar.gz
freebsd-ports-gnome-3bda34fefd54b4ff7a740b347c7931ce591fa28b.tar.zst
freebsd-ports-gnome-3bda34fefd54b4ff7a740b347c7931ce591fa28b.zip
- Fix a DoS issue
PR: ports/113942 Security: http://www.ossec.net/en/attacking-loganalysis.html#denyhosts Submitted by: David Bestor <freebsd1 at indenial.com> Approved by: Janos Mohacsi <mohacsi at niif.hu> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/denyhosts/Makefile1
-rw-r--r--security/denyhosts/files/patch-DenyHosts_regex.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
index 1c4e38473047..328840e3f1d3 100644
--- a/security/denyhosts/Makefile
+++ b/security/denyhosts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= denyhosts
PORTVERSION= 2.6
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/security/denyhosts/files/patch-DenyHosts_regex.py b/security/denyhosts/files/patch-DenyHosts_regex.py
new file mode 100644
index 000000000000..4c56fb519112
--- /dev/null
+++ b/security/denyhosts/files/patch-DenyHosts_regex.py
@@ -0,0 +1,11 @@
+--- DenyHosts/regex.py.orig Sat Jun 23 14:32:34 2007
++++ DenyHosts/regex.py Sat Jun 23 14:32:58 2007
+@@ -17,7 +17,7 @@
+
+ FAILED_ENTRY_REGEX4 = re.compile(r"""Authentication failure for (?P<user>.*) .*from (?P<host>.*)""")
+
+-FAILED_ENTRY_REGEX5 = re.compile(r"""User (?P<user>.*) .*from (?P<host>.*) not allowed because none of user's groups are listed in AllowGroups""")
++FAILED_ENTRY_REGEX5 = re.compile(r"""User (?P<user>.*) .*from (?P<host>.*) not allowed because none of user's groups are listed in AllowGroups$""")
+
+ FAILED_ENTRY_REGEX6 = re.compile(r"""Did not receive identification string .*from (::ffff:)?(?P<host>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})""")
+