aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-11-17 08:20:32 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-11-17 08:20:32 +0800
commit50c0c6b75943601adb02c51cb578989abc4b1916 (patch)
treeef9d8872e2d22f466637cc2720c0960b539b1e88 /security
parent0dba18a5acd4e0834ada07f33d6945521453f9ae (diff)
downloadfreebsd-ports-gnome-50c0c6b75943601adb02c51cb578989abc4b1916.tar.gz
freebsd-ports-gnome-50c0c6b75943601adb02c51cb578989abc4b1916.tar.zst
freebsd-ports-gnome-50c0c6b75943601adb02c51cb578989abc4b1916.zip
Lynis is an auditing tool for Unix (specialists). It scans the
system and available software, to detect security issues. Beside security related information it will also scan for general system information, installed packages and configuration mistakes. This software aims in assisting automated auditing, software patch management, vulnerability and malware scanning of Unix based systems. It can be run without prior installation, so inclusion on read only storage is no problem (USB stick, cd/dvd). WWW: http://www.rootkit.nl/projects/lynis.html Author: Michael Boelen PR: 128909 Submitted by: Cory McIntire <loon at noncensored dot com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/lynis/Makefile43
-rw-r--r--security/lynis/distinfo3
-rw-r--r--security/lynis/pkg-descr12
-rw-r--r--security/lynis/pkg-plist55
5 files changed, 114 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1867f12015f3..cfe1041764c3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -262,6 +262,7 @@
SUBDIR += logcheck
SUBDIR += lsh
SUBDIR += lxnb
+ SUBDIR += lynis
SUBDIR += mac-robber
SUBDIR += maia
SUBDIR += makepasswd
diff --git a/security/lynis/Makefile b/security/lynis/Makefile
new file mode 100644
index 000000000000..3d00bc029943
--- /dev/null
+++ b/security/lynis/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: Lynis
+# Date created: 15 November 2008
+# Whom: Cory McIntire (loon@noncensored.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= lynis
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= http://www.rootkit.nl/files/ \
+ http://downloads.rootkit.nl/
+
+MAINTAINER= loon@noncensored.com
+COMMENT= Security and system auditing tool
+
+NO_BUILD= yes
+
+PORTDOCS= *
+MAN8= lynis.8
+
+post-patch:
+ @${REINPLACE_CMD} -e '/tINCLUDE_TARGETS/ s|".*"|"${DATADIR}/include"|; \
+ /tPLUGIN_TARGETS/ s|".*"|"${DATADIR}/plugins"|; \
+ /tDB_TARGETS/ s|".*"|"${DATADIR}/db"|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${MANPREFIX}/man/man8
+ ${MKDIR} ${PREFIX}/etc/lynis
+ ${INSTALL_DATA} ${WRKSRC}/default.prf ${PREFIX}/etc/lynis
+ ${MKDIR} ${DATADIR}
+.for dir in include db dev plugins
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DATADIR}/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in CHANGELOG INSTALL FAQ LICENSE TODO README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/lynis/distinfo b/security/lynis/distinfo
new file mode 100644
index 000000000000..052ac08a8e8b
--- /dev/null
+++ b/security/lynis/distinfo
@@ -0,0 +1,3 @@
+MD5 (lynis-1.2.1.tar.gz) = 4f8db3c524c1014db5842ca2dbd575aa
+SHA256 (lynis-1.2.1.tar.gz) = 24e256770dbc5a50c2088eda6da9ba21c2136db6233e36af38c033cea4aa347f
+SIZE (lynis-1.2.1.tar.gz) = 72632
diff --git a/security/lynis/pkg-descr b/security/lynis/pkg-descr
new file mode 100644
index 000000000000..d2b2664f4533
--- /dev/null
+++ b/security/lynis/pkg-descr
@@ -0,0 +1,12 @@
+Lynis is an auditing tool for Unix (specialists). It scans the
+system and available software, to detect security issues. Beside
+security related information it will also scan for general system
+information, installed packages and configuration mistakes.
+
+This software aims in assisting automated auditing, software patch
+management, vulnerability and malware scanning of Unix based systems.
+It can be run without prior installation, so inclusion on read only
+storage is no problem (USB stick, cd/dvd).
+
+WWW: http://www.rootkit.nl/projects/lynis.html
+Author: Michael Boelen
diff --git a/security/lynis/pkg-plist b/security/lynis/pkg-plist
new file mode 100644
index 000000000000..050511f76332
--- /dev/null
+++ b/security/lynis/pkg-plist
@@ -0,0 +1,55 @@
+bin/lynis
+etc/lynis/default.prf
+%%DATADIR%%/db/fileperms.db
+%%DATADIR%%/db/integrity.db
+%%DATADIR%%/db/malware.db
+%%DATADIR%%/db/sbl.db
+%%DATADIR%%/dev/README
+%%DATADIR%%/dev/build-lynis.sh
+%%DATADIR%%/dev/files.dat
+%%DATADIR%%/dev/openbsd/+CONTENTS
+%%DATADIR%%/include/consts
+%%DATADIR%%/include/functions
+%%DATADIR%%/include/osdetection
+%%DATADIR%%/include/parameters
+%%DATADIR%%/include/profiles
+%%DATADIR%%/include/tests_accounting
+%%DATADIR%%/include/tests_authentication
+%%DATADIR%%/include/tests_banners
+%%DATADIR%%/include/tests_boot_services
+%%DATADIR%%/include/tests_crypto
+%%DATADIR%%/include/tests_databases
+%%DATADIR%%/include/tests_file_integrity
+%%DATADIR%%/include/tests_file_permissions
+%%DATADIR%%/include/tests_filesystems
+%%DATADIR%%/include/tests_firewalls
+%%DATADIR%%/include/tests_hardening
+%%DATADIR%%/include/tests_homedirs
+%%DATADIR%%/include/tests_kernel
+%%DATADIR%%/include/tests_ldap
+%%DATADIR%%/include/tests_logging
+%%DATADIR%%/include/tests_mac_frameworks
+%%DATADIR%%/include/tests_mail_messaging
+%%DATADIR%%/include/tests_malware
+%%DATADIR%%/include/tests_memory_processes
+%%DATADIR%%/include/tests_nameserver
+%%DATADIR%%/include/tests_networking
+%%DATADIR%%/include/tests_php
+%%DATADIR%%/include/tests_ports_packages
+%%DATADIR%%/include/tests_printers_spools
+%%DATADIR%%/include/tests_scheduling
+%%DATADIR%%/include/tests_shells
+%%DATADIR%%/include/tests_storage
+%%DATADIR%%/include/tests_time
+%%DATADIR%%/include/tests_virtualization
+%%DATADIR%%/include/tests_webservers
+%%DATADIR%%/plugins/README
+%%DATADIR%%/plugins/security_rootkit
+%%DATADIR%%/plugins/security_webvuln
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/include
+@dirrm %%DATADIR%%/dev/openbsd
+@dirrm %%DATADIR%%/dev
+@dirrm %%DATADIR%%/db
+@dirrm %%DATADIR%%
+@dirrm etc/lynis