aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpeter <peter@FreeBSD.org>1996-05-25 03:13:04 +0800
committerpeter <peter@FreeBSD.org>1996-05-25 03:13:04 +0800
commit59d0a4d2e3c5498ac2ac0fb660dbc290f0078620 (patch)
treee9f365a94e2c19970d3d1e46fcda6e016a05645a /security
parent16678d15082d807f71f500ece7a6245f8ba1d0ae (diff)
downloadfreebsd-ports-gnome-59d0a4d2e3c5498ac2ac0fb660dbc290f0078620.tar.gz
freebsd-ports-gnome-59d0a4d2e3c5498ac2ac0fb660dbc290f0078620.tar.zst
freebsd-ports-gnome-59d0a4d2e3c5498ac2ac0fb660dbc290f0078620.zip
Update the hack for locating wish/wish4.0 to also look for wish4.1 now
that we have that one too.
Diffstat (limited to 'security')
-rw-r--r--security/ssh/Makefile10
-rw-r--r--security/ssh2/Makefile10
2 files changed, 14 insertions, 6 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 5b09922876aa..6ec2039338ff 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.20 1996/03/24 23:04:17 ache Exp $
+# $Id: Makefile,v 1.21 1996/04/17 01:07:04 asami Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_WISH, USE_TCPWRAP
@@ -90,9 +90,13 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_WISH) && ${USE_WISH} == YES || \
- (exists(${PREFIX}/bin/wish4.0) || exists(${PREFIX}/bin/wish)) && \
+ (exists(${PREFIX}/bin/wish4.0) || exists(${PREFIX}/bin/wish4.1) || \
+ exists(${PREFIX}/bin/wish)) && \
(!defined(USE_WISH) || ${USE_WISH} != NO)
-.if exists(${PREFIX}/bin/wish4.0)
+.if exists(${PREFIX}/bin/wish4.1)
+BUILD_DEPENDS+= wish4.1:${PORTSDIR}/x11/tk41
+CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.1
+.elif exists(${PREFIX}/bin/wish4.0)
BUILD_DEPENDS+= wish4.0:${PORTSDIR}/x11/tk4
CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.0
.else
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 5b09922876aa..6ec2039338ff 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.20 1996/03/24 23:04:17 ache Exp $
+# $Id: Makefile,v 1.21 1996/04/17 01:07:04 asami Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_WISH, USE_TCPWRAP
@@ -90,9 +90,13 @@ post-install:
# Following stuff must be after <bsd.port.mk> to expand exists() properly
.if defined(USE_WISH) && ${USE_WISH} == YES || \
- (exists(${PREFIX}/bin/wish4.0) || exists(${PREFIX}/bin/wish)) && \
+ (exists(${PREFIX}/bin/wish4.0) || exists(${PREFIX}/bin/wish4.1) || \
+ exists(${PREFIX}/bin/wish)) && \
(!defined(USE_WISH) || ${USE_WISH} != NO)
-.if exists(${PREFIX}/bin/wish4.0)
+.if exists(${PREFIX}/bin/wish4.1)
+BUILD_DEPENDS+= wish4.1:${PORTSDIR}/x11/tk41
+CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.1
+.elif exists(${PREFIX}/bin/wish4.0)
BUILD_DEPENDS+= wish4.0:${PORTSDIR}/x11/tk4
CONFIGURE_ENV+= WISH=${PREFIX}/bin/wish4.0
.else