aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-06-28 10:52:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-06-28 10:52:18 +0800
commit5a49ddccbc479b801bfdb6098f3b68b556827702 (patch)
tree5bea8470e6993ea5afbe74d9ced0b3283f4dd3b5 /security
parentb225347d913e6e63695df5f79cddcfa88748271d (diff)
downloadfreebsd-ports-gnome-5a49ddccbc479b801bfdb6098f3b68b556827702.tar.gz
freebsd-ports-gnome-5a49ddccbc479b801bfdb6098f3b68b556827702.tar.zst
freebsd-ports-gnome-5a49ddccbc479b801bfdb6098f3b68b556827702.zip
- Update to 1.76
- Convert NOPORTEXAMPLES to new options framework - Use shared IDN and IPV6 option descriptions - Change IDN handler to p5-URI [1] - Update IPV6 handler to p5-IO-Socket-IP and p5-Socket - Costmetic change [1] To handle IDN, IO::Socket::SSL searches for the following modules: p5-Net-IDN-Encode, p5-Net-LibIDN and p5-URI. Since p5-URI is much more widely used by other ports, I suggest to use p5-URI as IDN handler. Changes: http://search.cpan.org/dist/IO-Socket-SSL/Changes PR: ports/169451 Submitted by: sunpoet (myself) Approved by: jadawin (maintainer, via IRC)
Diffstat (limited to 'security')
-rw-r--r--security/p5-IO-Socket-SSL/Makefile33
-rw-r--r--security/p5-IO-Socket-SSL/distinfo4
2 files changed, 18 insertions, 19 deletions
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
index c6feedf73b9f..4f8bce04e021 100644
--- a/security/p5-IO-Socket-SSL/Makefile
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= IO-Socket-SSL
-PORTVERSION= 1.74
+PORTVERSION= 1.76
CATEGORIES= security perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SULLR
@@ -15,36 +15,35 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Perl5 interface to SSL sockets
-RUN_DEPENDS= p5-Net-SSLeay>=1.21:${PORTSDIR}/security/p5-Net-SSLeay
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Net-SSLeay>=1.21:${PORTSDIR}/security/p5-Net-SSLeay
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= EXAMPLES IDN IPV6
PERL_CONFIGURE= yes
INSTALL_TARGET= pure_install
MAN3= IO::Socket::SSL.3
-
-OPTIONS_DEFINE= IDN IPV6
-IDN_DESC= International Domain Names (IDN) support
-IPV6_DESC= IPv6 support
-
-.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
-post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}
-.endif
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIDN}
-RUN_DEPENDS+= p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN
+RUN_DEPENDS+= p5-URI>=1.50:${PORTSDIR}/net/p5-URI
.endif
.if ${PORT_OPTIONS:MIPV6}
-RUN_DEPENDS+= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
+RUN_DEPENDS+= p5-IO-Socket-IP>=0.11:${PORTSDIR}/net/p5-IO-Socket-IP \
+ p5-Socket>=1.95:${PORTSDIR}/net/p5-Socket
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/example/* ${EXAMPLESDIR}/
.endif
-regression-test:
- @(cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} && ${MAKE} test)
+regression-test: build
+ cd ${WRKSRC}/ && ${MAKE} test
.include <bsd.port.mk>
diff --git a/security/p5-IO-Socket-SSL/distinfo b/security/p5-IO-Socket-SSL/distinfo
index 3ea1660b3b10..7c112988dd44 100644
--- a/security/p5-IO-Socket-SSL/distinfo
+++ b/security/p5-IO-Socket-SSL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (IO-Socket-SSL-1.74.tar.gz) = e080fae93663322a49c2cdf3eeeb5cad7bd9bf7ad9dd9f0147ddb57573fc2800
-SIZE (IO-Socket-SSL-1.74.tar.gz) = 75282
+SHA256 (IO-Socket-SSL-1.76.tar.gz) = a14d07edf8a1839481564ba9f9e9a07ecc95f51914e62a9264b4e858268d1870
+SIZE (IO-Socket-SSL-1.76.tar.gz) = 75442