aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-11-23 22:37:15 +0800
committerale <ale@FreeBSD.org>2011-11-23 22:37:15 +0800
commit5dbbdceb836dc73a6536f017ccef35be51ed7a13 (patch)
treec424ee1bd77dbfa934e85a359ba093c7fdf14492 /security
parent4364fd2b9d83f306d157b519c989a8902d3b14b4 (diff)
downloadfreebsd-ports-gnome-5dbbdceb836dc73a6536f017ccef35be51ed7a13.tar.gz
freebsd-ports-gnome-5dbbdceb836dc73a6536f017ccef35be51ed7a13.tar.zst
freebsd-ports-gnome-5dbbdceb836dc73a6536f017ccef35be51ed7a13.zip
The OATH Toolkit contains a shared library, command line tool
and a PAM module that makes it possible to build one-time password authentication systems. Supported technologies include the event-based HOTP algorithm and the time-based TOTP algorithm. OATH is the Open AuTHentication organization which specify the algorithms. The components included in the package is: - liboath: A shared and static C library for OATH handling. - oathtool: A command line tool for generating and validating OTPs. - pam_oath: A PAM module for pluggable login authentication for OATH. Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/oath-toolkit/Makefile47
-rw-r--r--security/oath-toolkit/distinfo2
-rw-r--r--security/oath-toolkit/pkg-descr14
-rw-r--r--security/oath-toolkit/pkg-plist10
5 files changed, 74 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 343e85a36645..285e88a38ceb 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -306,6 +306,7 @@
SUBDIR += nmap
SUBDIR += nmapsi4
SUBDIR += nss
+ SUBDIR += oath-toolkit
SUBDIR += ocaml-cryptgps
SUBDIR += ocaml-cryptokit
SUBDIR += ocaml-ssl
diff --git a/security/oath-toolkit/Makefile b/security/oath-toolkit/Makefile
new file mode 100644
index 000000000000..4dd5ee8dca4e
--- /dev/null
+++ b/security/oath-toolkit/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: oath-toolkit
+# Date created: 23 Nov 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oath-toolkit
+PORTVERSION= 1.10.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Library, tools and PAM module for OATH authentication
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+
+MAN1= oathtool.1
+
+DOCS= AUTHORS ChangeLog NEWS README
+
+PORTDOCS= *
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} 's|install-data-am: install-data-local|install-data-am:|' \
+ ${WRKSRC}/liboath/gtk-doc/Makefile.in
+.else
+ @${REINPLACE_CMD} 's|@HTML_DIR@|${DOCSDIR}|' \
+ ${WRKSRC}/liboath/gtk-doc/Makefile.in
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+ ${MKDIR} ${DOCSDIR}/pam_oath
+ ${INSTALL_DATA} ${WRKSRC}/pam_oath/README ${DOCSDIR}/pam_oath/
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/oath-toolkit/distinfo b/security/oath-toolkit/distinfo
new file mode 100644
index 000000000000..df91a2f70cc1
--- /dev/null
+++ b/security/oath-toolkit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (oath-toolkit-1.10.0.tar.gz) = d9d6180b7b22fe7cf624753c4bf2dc400da1e1aa6ef30d21358e3a3e2a5c9c14
+SIZE (oath-toolkit-1.10.0.tar.gz) = 1792440
diff --git a/security/oath-toolkit/pkg-descr b/security/oath-toolkit/pkg-descr
new file mode 100644
index 000000000000..b77849278274
--- /dev/null
+++ b/security/oath-toolkit/pkg-descr
@@ -0,0 +1,14 @@
+The OATH Toolkit contains a shared library, command line tool
+and a PAM module that makes it possible to build one-time
+password authentication systems. Supported technologies include
+the event-based HOTP algorithm and the time-based TOTP algorithm.
+OATH is the Open AuTHentication organization which specify
+the algorithms.
+
+The components included in the package is:
+
+- liboath: A shared and static C library for OATH handling.
+- oathtool: A command line tool for generating and validating OTPs.
+- pam_oath: A PAM module for pluggable login authentication for OATH.
+
+WWW: http://www.nongnu.org/oath-toolkit/
diff --git a/security/oath-toolkit/pkg-plist b/security/oath-toolkit/pkg-plist
new file mode 100644
index 000000000000..066d3044da6a
--- /dev/null
+++ b/security/oath-toolkit/pkg-plist
@@ -0,0 +1,10 @@
+bin/oathtool
+include/liboath/oath.h
+lib/liboath.a
+lib/liboath.la
+lib/liboath.so
+lib/liboath.so.1
+lib/security/pam_oath.so
+libdata/pkgconfig/liboath.pc
+@dirrm include/liboath
+@dirrmtry lib/security