aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-02-16 06:42:08 +0800
committerjgh <jgh@FreeBSD.org>2012-02-16 06:42:08 +0800
commit5fd9149cfc072664676d6cc8504575ad1c49e258 (patch)
tree479b2e5e017556de350866f27a03940e3c7a5dfd /security
parent01a85540adf3cfbadc1fc0f9a12d33ef3a6f0667 (diff)
downloadfreebsd-ports-gnome-5fd9149cfc072664676d6cc8504575ad1c49e258.tar.gz
freebsd-ports-gnome-5fd9149cfc072664676d6cc8504575ad1c49e258.tar.zst
freebsd-ports-gnome-5fd9149cfc072664676d6cc8504575ad1c49e258.zip
Add new port (security/tsshbatch)
'tsshbatch' is a tool to enable you to issue a command to many servers without having to log into each one separately. When writing scripts, this overcomes the 'ssh' limitation of not being able to specify the password on the command line. 'tsshbatch' also understands basic 'sudo' syntax and can be used to access a server, 'sudo' a command, and then exit. 'tsshbatch' thus allows you to write complex, hands-off scripts that issue commands to many servers without the tedium of manual login and 'sudo' promotion. System administrators, especially, will find this helpful when working in large server farms. WWW: http://www.tundraware.com/Software/tsshbatch PR: ports/163866 Submitted by: Tim Daneliuk, tsshbatch at tundraware.com
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/tsshbatch/Makefile47
-rw-r--r--security/tsshbatch/distinfo2
-rw-r--r--security/tsshbatch/pkg-descr14
4 files changed, 64 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f9704459de42..92993f294620 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -906,6 +906,7 @@
SUBDIR += tripwire12
SUBDIR += trousers
SUBDIR += truecrypt
+ SUBDIR += tsshbatch
SUBDIR += tthsum
SUBDIR += tuntun
SUBDIR += umit
diff --git a/security/tsshbatch/Makefile b/security/tsshbatch/Makefile
new file mode 100644
index 000000000000..802a304f8711
--- /dev/null
+++ b/security/tsshbatch/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: tsshbatch
+# Date created: 06 January 2012
+# Whom: Tim Daneliuk <tsshbatch@tundraware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tsshbatch
+PORTVERSION= 1.134
+CATEGORIES= security python
+MASTER_SITES= http://www.tundraware.com/Software/tsshbatch/
+
+MAINTAINER= tsshbatch@tundraware.com
+COMMENT= Batch ssh Operations
+
+LICENSE= tsshbatch
+LICENSE_NAME= tsshbatch
+LICENSE_FILE= ${WRKSRC}/tsshbatch-license.txt
+LICENSE_PERMS= auto-accept
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.7.7.1:${PORTSDIR}/security/py-paramiko
+
+USE_PYTHON_RUN= yes
+
+MAN1= tsshbatch.1
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/tsshbatch.py
+PORTDOCS= WHATSNEW.txt \
+ tsshbatch.html \
+ tsshbatch.pdf \
+ tsshbatch.ps \
+ tsshbatch.rst
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tsshbatch.py ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tsshbatch.1.gz ${MAN1PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ cd ${WRKSRC} && ${INSTALL_DATA} $i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/tsshbatch/distinfo b/security/tsshbatch/distinfo
new file mode 100644
index 000000000000..35afd11541f2
--- /dev/null
+++ b/security/tsshbatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tsshbatch-1.134.tar.gz) = 564e1fa4a4446d19d0c1169e6d961f74e8427b5eeb61ef89f3a7362635234e5d
+SIZE (tsshbatch-1.134.tar.gz) = 211833
diff --git a/security/tsshbatch/pkg-descr b/security/tsshbatch/pkg-descr
new file mode 100644
index 000000000000..5c7acedcbc5e
--- /dev/null
+++ b/security/tsshbatch/pkg-descr
@@ -0,0 +1,14 @@
+'tsshbatch' is a tool to enable you to issue a command to many
+servers without having to log into each one separately. When writing
+scripts, this overcomes the 'ssh' limitation of not being able to
+specify the password on the command line.
+
+'tsshbatch' also understands basic 'sudo' syntax and can be used
+to access a server, 'sudo' a command, and then exit.
+
+'tsshbatch' thus allows you to write complex, hands-off scripts that
+issue commands to many servers without the tedium of manual login and
+'sudo' promotion. System administrators, especially, will find this
+helpful when working in large server farms.
+
+WWW: http://www.tundraware.com/Software/tsshbatch