aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-08-05 08:33:28 +0800
committerswills <swills@FreeBSD.org>2011-08-05 08:33:28 +0800
commit6e01a2bb5e9f9500a0eb4b617ca4ceaf6505745d (patch)
tree91abfd340a14e8a0f1e4962e56e9524a5dce6e22 /security
parentdf9af266fbe6375cc89a5733ede42985e8d696e1 (diff)
downloadfreebsd-ports-gnome-6e01a2bb5e9f9500a0eb4b617ca4ceaf6505745d.tar.gz
freebsd-ports-gnome-6e01a2bb5e9f9500a0eb4b617ca4ceaf6505745d.tar.zst
freebsd-ports-gnome-6e01a2bb5e9f9500a0eb4b617ca4ceaf6505745d.zip
- Fix build with Ruby 1.9
With hat: ruby@
Diffstat (limited to 'security')
-rw-r--r--security/dradis/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/dradis/Makefile b/security/dradis/Makefile
index 5a863b157256..554043ab88d9 100644
--- a/security/dradis/Makefile
+++ b/security/dradis/Makefile
@@ -15,9 +15,8 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= semprix@gmx.com
COMMENT= Opensource framework to enable effective information gathering
-RUN_DEPENDS= ruby18-gems>=1.3.6:${PORTSDIR}/devel/ruby-gems \
- ruby18-iconv>=1.8.7.302,1:${PORTSDIR}/converters/ruby-iconv \
- ruby18-wirble>=0.1.3:${PORTSDIR}/devel/ruby-wirble \
+RUN_DEPENDS= ${LOCALBASE}/bin/gem:${PORTSDIR}/devel/ruby-gems \
+ ${RUBY_SITELIBDIR}/wirble.rb:${PORTSDIR}/devel/ruby-wirble \
rubygem-rake>=0.8.7:${PORTSDIR}/devel/rubygem-rake \
rubygem-rails>=3.0.5:${PORTSDIR}/www/rubygem-rails \
rubygem-activesupport>=3.0.2:${PORTSDIR}/devel/rubygem-activesupport \
@@ -37,6 +36,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:R}
NO_BUILD= yes
USE_RUBY= yes
+USE_RUBY_FEATURES= iconv
RUBY_SHEBANG_FILES= server/script/rails server/script/delayed_job
RUBY_NO_BUILD_DEPENDS= yes