aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /security
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'security')
-rw-r--r--security/aide/Makefile2
-rw-r--r--security/mhash/Makefile2
-rw-r--r--security/seahorse/Makefile2
-rw-r--r--security/snort/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index f1e6619d739c..425edabfc9a2 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS+=--with-mhash \
--with-zlib \
--with-config_file=/var/adm/aide/aide.conf
-CONFIGURE_ENV+= LIBS='-L${LOCALBASE}/lib -pthread'
+CONFIGURE_ENV+= LIBS='-L${LOCALBASE}/lib ${PTHREAD_LIBS}'
MAN1= aide.1
MAN5= aide.conf.5
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index 1d6ada595847..629342750f07 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= roam@FreeBSD.org
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS+= --with-LDFLAGS="-pthread"
+CONFIGURE_ARGS+= --with-LDFLAGS="${PTHREAD_LIBS}"
MAN3= mhash.3
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 328b46ab1c27..3cceebe7c7d5 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= seahorse.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|datadir\`/gnome/|datadir\`/|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 947b608fea22..e52fe63e6577 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ARGS+=--with-mysql-includes=${LOCALBASE}/include/mysql \
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+=--with-unixodbc-includes=${LOCALBASE}/include \
--with-unixodbc-libraries=${LOCALBASE}/lib
-LDFLAGS+= -pthread
+LDFLAGS+= ${PTHREAD_LIBS}
.endif
.if defined(WITH_POSTGRES)