aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-06-30 23:33:35 +0800
committergahr <gahr@FreeBSD.org>2014-06-30 23:33:35 +0800
commit6f7ad32d7d2147e15ba32e71c78029a4b6a28358 (patch)
treeca2644b68233f36dd4192b2d68f2ebeaa6d82c42 /security
parenteca9edac62c5ef55b3897c56a185609a2aaf5e0e (diff)
downloadfreebsd-ports-gnome-6f7ad32d7d2147e15ba32e71c78029a4b6a28358.tar.gz
freebsd-ports-gnome-6f7ad32d7d2147e15ba32e71c78029a4b6a28358.tar.zst
freebsd-ports-gnome-6f7ad32d7d2147e15ba32e71c78029a4b6a28358.zip
- STAGE-clean
Diffstat (limited to 'security')
-rw-r--r--security/libtomcrypt/Makefile7
-rw-r--r--security/libtomcrypt/files/patch-makefile4
2 files changed, 5 insertions, 6 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index bee5318ede37..00651feac5ff 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -13,13 +13,13 @@ COMMENT= Comprehensive, modular, and portable cryptographic toolkit
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
-MAKE_ARGS= DESTDIR="${PREFIX}" LIBPATH="/lib" INCPATH="/include" \
- DATAPATH="${DOCSDIR}/pdf"
+MAKE_ARGS= DESTDIR="${STAGEDIR}" LIBPATH="${PREFIX}/lib" \
+ INCPATH="${PREFIX}/include" DATAPATH="${DOCSDIR}/pdf"
USES= gmake tar:bzip2
ALL_TARGET= library
-CFLAGS+= -I${PREFIX}/include
+CFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT= LIBTOMMATH
@@ -28,7 +28,6 @@ OPTIONS_MULTI_MATH= LIBTOMMATH TOMSFASTMATH GMP
LIBTOMMATH_DESC= Use LibTomMath
TOMSFASTMATH_DESC= Use TomsFastMath
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIBTOMMATH}
diff --git a/security/libtomcrypt/files/patch-makefile b/security/libtomcrypt/files/patch-makefile
index c1c8fa8207d8..b03278144405 100644
--- a/security/libtomcrypt/files/patch-makefile
+++ b/security/libtomcrypt/files/patch-makefile
@@ -31,8 +31,8 @@
install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
ifndef NODOCS
- install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DESTDIR)$(DATAPATH)
-+ install -d -g $(GROUP) -o $(USER) $(DATAPATH)
-+ install -g $(GROUP) -o $(USER) doc/crypt.pdf $(DATAPATH)
++ install -d -g $(GROUP) -o $(USER) ${DESTDIR}$(DATAPATH)
++ install -g $(GROUP) -o $(USER) doc/crypt.pdf ${DESTDIR}$(DATAPATH)
endif
install_test: testprof/$(LIBTEST)