aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
commit72ce7050d03c812e37966786e11996a90713afea (patch)
tree9ec01d647da1c4e80223e31fc766740c2a43ebff /security
parent97830337b8c0333a12d15a49ea1f9c9cdc3dfddf (diff)
downloadfreebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.gz
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.zst
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.zip
Implement USE_GTK, part 2.
Diffstat (limited to 'security')
-rw-r--r--security/gpa/Makefile6
-rw-r--r--security/gpasman/Makefile5
-rw-r--r--security/gtkportscan/Makefile7
-rw-r--r--security/nessus-devel/Makefile16
-rw-r--r--security/nessus/Makefile16
-rw-r--r--security/nmapfe/Makefile3
-rw-r--r--security/zenmap/Makefile3
7 files changed, 22 insertions, 34 deletions
diff --git a/security/gpa/Makefile b/security/gpa/Makefile
index 4c9494615f1b..94d8cf1be03d 100644
--- a/security/gpa/Makefile
+++ b/security/gpa/Makefile
@@ -12,17 +12,13 @@ MASTER_SITES= ftp://ftp.gnupg.org/pub/gcrypt/devel/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GTK= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- MAKE="gmake" \
- GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/security/gpasman/Makefile b/security/gpasman/Makefile
index b340deace0fb..28a93eae302c 100644
--- a/security/gpasman/Makefile
+++ b/security/gpasman/Makefile
@@ -12,12 +12,9 @@ MASTER_SITES= http://gpasman.nl.linux.org/
MAINTAINER= domi@saargate.de
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_GTK= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
diff --git a/security/gtkportscan/Makefile b/security/gtkportscan/Makefile
index 2fc2cb8c08c3..571e64eb5285 100644
--- a/security/gtkportscan/Makefile
+++ b/security/gtkportscan/Makefile
@@ -13,11 +13,8 @@ MASTER_SITE_SUBDIR= cpiazza
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+WRKSRC= ${WRKDIR}/${PORTNAME}
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+USE_GTK= yes
.include <bsd.port.mk>
diff --git a/security/nessus-devel/Makefile b/security/nessus-devel/Makefile
index 72d5a29fd058..2b223a7811b0 100644
--- a/security/nessus-devel/Makefile
+++ b/security/nessus-devel/Makefile
@@ -21,24 +21,24 @@ DISTNAME= nessus-core-1.0.4
MAINTAINER= anders@fix.no
-LIB_DEPENDS= nasl.1:${PORTSDIR}/security/nessus-libnasl \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+LIB_DEPENDS= nasl.1:${PORTSDIR}/security/nessus-libnasl
NESSUS_REV= ${DISTNAME:S/nessus-core-//g}
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/nessus-core
-GNU_CONFIGURE= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
+
MAN1= nessus.1
MAN8= nessusd.8 nessus-adduser.8
post-install:
- @${ECHO} "=========================================================="
- @${ECHO} "Be sure to erase your old ${PREFIX}/etc/nessus!"
- @${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
- @${ECHO} "=========================================================="
+ @${ECHO} "=========================================================="
+ @${ECHO} "Be sure to erase your old ${PREFIX}/etc/nessus!"
+ @${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
+ @${ECHO} "=========================================================="
.include <bsd.port.mk>
diff --git a/security/nessus/Makefile b/security/nessus/Makefile
index 72d5a29fd058..2b223a7811b0 100644
--- a/security/nessus/Makefile
+++ b/security/nessus/Makefile
@@ -21,24 +21,24 @@ DISTNAME= nessus-core-1.0.4
MAINTAINER= anders@fix.no
-LIB_DEPENDS= nasl.1:${PORTSDIR}/security/nessus-libnasl \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+LIB_DEPENDS= nasl.1:${PORTSDIR}/security/nessus-libnasl
NESSUS_REV= ${DISTNAME:S/nessus-core-//g}
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/nessus-core
-GNU_CONFIGURE= yes
+USE_GTK= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= GTKCONFIG="${GTK_CONFIG}"
+
MAN1= nessus.1
MAN8= nessusd.8 nessus-adduser.8
post-install:
- @${ECHO} "=========================================================="
- @${ECHO} "Be sure to erase your old ${PREFIX}/etc/nessus!"
- @${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
- @${ECHO} "=========================================================="
+ @${ECHO} "=========================================================="
+ @${ECHO} "Be sure to erase your old ${PREFIX}/etc/nessus!"
+ @${ECHO} "The syntax of nessusd.users and nessusd.rules has changed!"
+ @${ECHO} "=========================================================="
.include <bsd.port.mk>
diff --git a/security/nmapfe/Makefile b/security/nmapfe/Makefile
index 6eb371aeaa62..215ef89aebc3 100644
--- a/security/nmapfe/Makefile
+++ b/security/nmapfe/Makefile
@@ -15,14 +15,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
.include <bsd.port.pre.mk>
USE_XLIB= yes
+USE_GTK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
WRKSRC:= ${WRKDIR}/nmapfe
do-install:
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
index 6eb371aeaa62..215ef89aebc3 100644
--- a/security/zenmap/Makefile
+++ b/security/zenmap/Makefile
@@ -15,14 +15,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= obrien@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
.include <bsd.port.pre.mk>
USE_XLIB= yes
+USE_GTK= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
WRKSRC:= ${WRKDIR}/nmapfe
do-install: