aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:27:24 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:27:24 +0800
commit77bd57fb64916733a29c75421f2112c92ccf878f (patch)
tree7f4f7571ac2dffd8fa6d58591266b50d64ba178f /security
parent8a9848a879307d8f7905de889b34a75adec4ae53 (diff)
downloadfreebsd-ports-gnome-77bd57fb64916733a29c75421f2112c92ccf878f.tar.gz
freebsd-ports-gnome-77bd57fb64916733a29c75421f2112c92ccf878f.tar.zst
freebsd-ports-gnome-77bd57fb64916733a29c75421f2112c92ccf878f.zip
Add p5-Crypt-Twofish 1.0, perl module implementing the Twofish cipher.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Twofish/Makefile24
-rw-r--r--security/p5-Crypt-Twofish/distinfo1
-rw-r--r--security/p5-Crypt-Twofish/pkg-comment1
-rw-r--r--security/p5-Crypt-Twofish/pkg-descr5
-rw-r--r--security/p5-Crypt-Twofish/pkg-plist7
6 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4218035aaa7c..ffee2622d832 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -82,6 +82,7 @@
SUBDIR += p5-Crypt-Rijndael
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Crypt-TripleDES
+ SUBDIR += p5-Crypt-Twofish
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
SUBDIR += p5-IO-Socket-SSL
diff --git a/security/p5-Crypt-Twofish/Makefile b/security/p5-Crypt-Twofish/Makefile
new file mode 100644
index 000000000000..9a3097710261
--- /dev/null
+++ b/security/p5-Crypt-Twofish/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Twofish
+# Date created: Wed Jan 3 16:29:03 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Twofish
+PORTVERSION= 1.0
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/Crypt/Twofish
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::Twofish.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Twofish/distinfo b/security/p5-Crypt-Twofish/distinfo
new file mode 100644
index 000000000000..f23bacf70b7e
--- /dev/null
+++ b/security/p5-Crypt-Twofish/distinfo
@@ -0,0 +1 @@
+MD5 (Twofish-1.0.tar.gz) = 0c4d916aee5f0978bca2314a84b23b2c
diff --git a/security/p5-Crypt-Twofish/pkg-comment b/security/p5-Crypt-Twofish/pkg-comment
new file mode 100644
index 000000000000..c01c0b1e6308
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing the Twofish cipher
diff --git a/security/p5-Crypt-Twofish/pkg-descr b/security/p5-Crypt-Twofish/pkg-descr
new file mode 100644
index 000000000000..f5b246ad853e
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-descr
@@ -0,0 +1,5 @@
+Crypt::Twofish is a perl module implementing the Twofish cipher.
+
+Author: Nishant Kakani <nishantkakani@hotmail.com>
+
+--will
diff --git a/security/p5-Crypt-Twofish/pkg-plist b/security/p5-Crypt-Twofish/pkg-plist
new file mode 100644
index 000000000000..e87c131dfd8a
--- /dev/null
+++ b/security/p5-Crypt-Twofish/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/Twofish.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/Twofish.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/Twofish.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/Twofish.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/Twofish