aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-07-20 05:14:30 +0800
committerzi <zi@FreeBSD.org>2011-07-20 05:14:30 +0800
commit8a9fc47d86467147d96a47ed6479928ac540887b (patch)
treebb597cbbde76b2b2a1b54ca0ee105f194b79877d /security
parentb53c42a6330c0b86f13adc8e0da5babe852184f9 (diff)
downloadfreebsd-ports-gnome-8a9fc47d86467147d96a47ed6479928ac540887b.tar.gz
freebsd-ports-gnome-8a9fc47d86467147d96a47ed6479928ac540887b.tar.zst
freebsd-ports-gnome-8a9fc47d86467147d96a47ed6479928ac540887b.zip
Add DAG Support
Fix build when using custom LOCALBASE/PREFIX Pacify portlint(1) PR: ports/158147 Submitted by: rpsfa@rit.edu (me) Approved by: maintainer timeout, tabthorpe (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/suricata/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index e6a8b9e7bc4c..c44601ca2089 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -14,6 +14,9 @@ MASTER_SITES= http://openinfosecfoundation.org/download/ \
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= Open Source next generation IDS/IPS engine by OISF
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
yaml:${PORTSDIR}/textproc/libyaml \
pcap.1:${PORTSDIR}/net/libpcap
@@ -28,7 +31,10 @@ USE_RC_SUBR= suricata
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
OPTIONS= IPFW "Enable IPFW/IPDIVERT for IPS usage" on \
- PRELUDE "Enable Prelude NIDS integration" off
+ PRELUDE "Enable Prelude NIDS integration" off \
+ DAG "Enable Endace DAG Support" off
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
SUB_FILES= pkg-message
HAS_CONFIGURE= yes
@@ -40,9 +46,6 @@ CONFIG_FILES= suricata.yaml classification.config
RULES_DIR= ${PREFIX}/etc/suricata/rules
LOGS_DIR= /var/log/suricata
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
@@ -62,6 +65,10 @@ PLIST_SUB+= PRELUDE=""
CONFIGURE_ARGS+= --enable-ipfw
.endif
+.if defined(WITH_DAG)
+CONFIGURE_ARGS+= --enable-dag
+.endif
+
pre-install:
@${REINPLACE_CMD} -e 's|/etc/suricata|${PREFIX}/etc/suricata|g' ${WRKSRC}/suricata.yaml