aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 00:24:24 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 00:24:24 +0800
commit90c8f6433a9ba797381995da8f73ad6a6d4e566b (patch)
treec17cb9527802b77a131ef858beb2798f2c55e9a5 /security
parent0a630c5f5083b825f1b1014861b1b3e36094fc59 (diff)
downloadfreebsd-ports-gnome-90c8f6433a9ba797381995da8f73ad6a6d4e566b.tar.gz
freebsd-ports-gnome-90c8f6433a9ba797381995da8f73ad6a6d4e566b.tar.zst
freebsd-ports-gnome-90c8f6433a9ba797381995da8f73ad6a6d4e566b.zip
A set of extra definitions, default values and helpers for the tls
package. WWW: http://github.com/vincenthz/hs-tls-extra Obtained from: FreeBSD Haskell
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/hs-tls-extra/Makefile24
-rw-r--r--security/hs-tls-extra/distinfo2
-rw-r--r--security/hs-tls-extra/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 448a2eb64e25..d3c5529ba7d0 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -200,6 +200,7 @@
SUBDIR += hs-pwstore-fast
SUBDIR += hs-skein
SUBDIR += hs-tls
+ SUBDIR += hs-tls-extra
SUBDIR += httprint
SUBDIR += hunch
SUBDIR += hydra
diff --git a/security/hs-tls-extra/Makefile b/security/hs-tls-extra/Makefile
new file mode 100644
index 000000000000..de8fcfa5f6bd
--- /dev/null
+++ b/security/hs-tls-extra/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-tls-extra
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tls-extra
+PORTVERSION= 0.4.2.1
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= TLS extra default values and helpers
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= certificate>=1.0.0 crypto-api>=0.5 cryptocipher>=0.3.0 \
+ cryptohash>=0.6 mtl network>=2.3 text>=0.5 tls>=0.8.4 \
+ vector
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-tls-extra/distinfo b/security/hs-tls-extra/distinfo
new file mode 100644
index 000000000000..0c0dbc4cc1ca
--- /dev/null
+++ b/security/hs-tls-extra/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/tls-extra-0.4.2.1.tar.gz) = a6c8dae893d8eaa056001f65535347984474561689fa4de593336f7b8bd6ad3d
+SIZE (cabal/tls-extra-0.4.2.1.tar.gz) = 12500
diff --git a/security/hs-tls-extra/pkg-descr b/security/hs-tls-extra/pkg-descr
new file mode 100644
index 000000000000..86d22c548bd7
--- /dev/null
+++ b/security/hs-tls-extra/pkg-descr
@@ -0,0 +1,4 @@
+A set of extra definitions, default values and helpers for the tls
+package.
+
+WWW: http://github.com/vincenthz/hs-tls-extra