aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-24 19:45:09 +0800
committeredwin <edwin@FreeBSD.org>2003-08-24 19:45:09 +0800
commit9b27e66a4d3685fc4bd6ac27b144573a57f8a89c (patch)
treec9003117e5ae6da3b1e48665d2f52380dc0bd8fe /security
parent983c074eeedb94cc818a99dff01f767db670c08e (diff)
downloadfreebsd-ports-gnome-9b27e66a4d3685fc4bd6ac27b144573a57f8a89c.tar.gz
freebsd-ports-gnome-9b27e66a4d3685fc4bd6ac27b144573a57f8a89c.tar.zst
freebsd-ports-gnome-9b27e66a4d3685fc4bd6ac27b144573a57f8a89c.zip
new port: Security scanner for Samba
ADM smb is a security scanner for Samba /* based on the src of the smbclient from the samba team */ ADMsmb will perform a complete audit of samba for you on a host you provide. PR: ports/53696 Submitted by: Jacek Serwatynski <tutus@trynet.eu.org>
Diffstat (limited to 'security')
-rw-r--r--security/ADMsmb/Makefile23
-rw-r--r--security/ADMsmb/distinfo1
-rw-r--r--security/ADMsmb/pkg-descr7
-rw-r--r--security/ADMsmb/pkg-plist3
-rw-r--r--security/Makefile1
5 files changed, 35 insertions, 0 deletions
diff --git a/security/ADMsmb/Makefile b/security/ADMsmb/Makefile
new file mode 100644
index 000000000000..bbb9cd6013f3
--- /dev/null
+++ b/security/ADMsmb/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: ADMsmb
+# Date created: 23 Jun 2003
+# Whom: tutus@trynet.eu.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ADMsmb
+PORTVERSION= 0.3
+CATEGORIES= security
+MASTER_SITES= http://www.geocities.com/bofn1001/ \
+ http://adm.freelsd.net/ADM/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Security scanner for Samba
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ADMsmb ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/ADMsmb
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/ADMsmb
+
+.include <bsd.port.mk>
diff --git a/security/ADMsmb/distinfo b/security/ADMsmb/distinfo
new file mode 100644
index 000000000000..50be6bacf01e
--- /dev/null
+++ b/security/ADMsmb/distinfo
@@ -0,0 +1 @@
+MD5 (ADMsmb_0.3.tar.gz) = 2435211471f870c0bb0b775e1d67c553
diff --git a/security/ADMsmb/pkg-descr b/security/ADMsmb/pkg-descr
new file mode 100644
index 000000000000..c94960f52d25
--- /dev/null
+++ b/security/ADMsmb/pkg-descr
@@ -0,0 +1,7 @@
+ADM smb is a security scanner for Samba
+/* based on the src of the smbclient from the samba team */
+ADMsmb will perform a complete audit of samba for you on a host you
+provide.
+
+- Jacek Serwatynski
+tutus@trynet.eu.org
diff --git a/security/ADMsmb/pkg-plist b/security/ADMsmb/pkg-plist
new file mode 100644
index 000000000000..790982d09799
--- /dev/null
+++ b/security/ADMsmb/pkg-plist
@@ -0,0 +1,3 @@
+bin/ADMsmb
+share/ADMsmb/README
+@dirrm share/ADMsmb
diff --git a/security/Makefile b/security/Makefile
index 6cef2e254208..baea4376d438 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
#
+ SUBDIR += ADMsmb
SUBDIR += ADMsnmp
SUBDIR += aafid2
SUBDIR += acid