aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-03-08 23:40:53 +0800
committerswills <swills@FreeBSD.org>2012-03-08 23:40:53 +0800
commita59847b770ef8d48a84d970d971758e02318944a (patch)
tree9a111516b14bcdb288dbbc51010a4c6f967b0b56 /security
parent19c193cf6cf8cd94a156377a9a1f5d0f8b806459 (diff)
downloadfreebsd-ports-gnome-a59847b770ef8d48a84d970d971758e02318944a.tar.gz
freebsd-ports-gnome-a59847b770ef8d48a84d970d971758e02318944a.tar.zst
freebsd-ports-gnome-a59847b770ef8d48a84d970d971758e02318944a.zip
- Include BUILD_DEPENDS as well as RUN_DEPENDS since the module seems to
hard code the paths to the pgp/gpg at build time - Switch to gpg as default since tests fail on 64bit with pgp for me and more folks are likely to have gpg already installed since it seems more common these days
Diffstat (limited to 'security')
-rw-r--r--security/p5-PGP-Sign/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index c320ef61d233..df339ada2d87 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PGP-Sign
PORTVERSION= 0.20
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -29,16 +30,18 @@ MAN3= PGP::Sign.3
# GPG - Gnu Privacy Guard
.ifndef DEFAULTPGP
-DEFAULTPGP= PGP2
+DEFAULTPGP= GPG
.endif
.if (${DEFAULTPGP} == PGP2 )
+BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
PGPSTYLE?= PGP2
.ifndef PGP
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == PGP5 )
+BUILD_DEPENDS= pgps:${PORTSDIR}/security/pgp5
RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
PGPSTYLE?= PGP5
.ifndef PGPS
@@ -51,6 +54,7 @@ PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == GPG)
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
PGPSTYLE?= GPG
.ifndef PGP