aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2005-02-27 04:23:15 +0800
committerume <ume@FreeBSD.org>2005-02-27 04:23:15 +0800
commitae8084c0d41c3a2e07973dae1722afb7a26dd496 (patch)
tree009b69812f2a6df7b3f0a1b34cd6095b83c509de /security
parent6b3f6585a981bea3c94f966e9ed74d0216ee6309 (diff)
downloadfreebsd-ports-gnome-ae8084c0d41c3a2e07973dae1722afb7a26dd496.tar.gz
freebsd-ports-gnome-ae8084c0d41c3a2e07973dae1722afb7a26dd496.tar.zst
freebsd-ports-gnome-ae8084c0d41c3a2e07973dae1722afb7a26dd496.zip
backout use of USE_INC_LIBTOOL_VER. libtool13 is marked as
DEPRECATED. libtool15 is incompatible, and I couldn't find how to build and install static libs by libtool15. Suggensted by: Angelo Turetta <aturetta@commit.it>
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2/Makefile1
-rw-r--r--security/cyrus-sasl2/files/patch-config::ltmain.sh33
2 files changed, 33 insertions, 1 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index af97c1fb35c2..6a18d9df1a9c 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -41,7 +41,6 @@ MAN3= sasl.3 sasl_authorize_t.3 sasl_auxprop.3 \
MAN8= sasldblistusers2.8 saslpasswd2.8
USE_OPENSSL= yes
-USE_INC_LIBTOOL_VER= 13
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
diff --git a/security/cyrus-sasl2/files/patch-config::ltmain.sh b/security/cyrus-sasl2/files/patch-config::ltmain.sh
new file mode 100644
index 000000000000..0471b82685ca
--- /dev/null
+++ b/security/cyrus-sasl2/files/patch-config::ltmain.sh
@@ -0,0 +1,33 @@
+Index: config/ltmain.sh
+diff -u config/ltmain.sh.orig config/ltmain.sh
+--- config/ltmain.sh.orig Wed Jul 2 22:29:00 2003
++++ config/ltmain.sh Wed Jul 16 02:57:20 2003
+@@ -1901,7 +1901,7 @@
+ deplib_matches=`eval \\$echo \"$library_names_spec\"`
+ set dummy $deplib_matches
+ deplib_match=$2
+- if test `expr "$ldd_output" : ".*$deplib_match"` -ne 0 ; then
++ if test `expr "X$ldd_output" : "X.*$deplib_match"` -ne 0 ; then
+ newdeplibs="$newdeplibs $i"
+ else
+ droppeddeps=yes
+@@ -1931,7 +1931,7 @@
+ deplib_matches=`eval \\$echo \"$library_names_spec\"`
+ set dummy $deplib_matches
+ deplib_match=$2
+- if test `expr "$ldd_output" : ".*$deplib_match"` -ne 0 ; then
++ if test `expr "X$ldd_output" : "X.*$deplib_match"` -ne 0 ; then
+ newdeplibs="$newdeplibs $i"
+ else
+ droppeddeps=yes
+@@ -3396,8 +3396,8 @@
+ # Install the pseudo-library for information purposes.
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+- $show "$install_prog $instname $destdir/$name"
+- $run eval "$install_prog $instname $destdir/$name" || exit $?
++ #$show "$install_prog $instname $destdir/$name"
++ #$run eval "$install_prog $instname $destdir/$name" || exit $?
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"