aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-08-22 05:00:33 +0800
committerdougb <dougb@FreeBSD.org>2012-08-22 05:00:33 +0800
commitb27652b43bdb1dc4a973d1db0d0da523579e215b (patch)
tree687cc3167fd1d7bdcfa54b68496dfda41bdf40fa /security
parent0ebe4ddc54831b4e06084ce6d046dbba142175ce (diff)
downloadfreebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.tar.gz
freebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.tar.zst
freebsd-ports-gnome-b27652b43bdb1dc4a973d1db0d0da523579e215b.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied.
Diffstat (limited to 'security')
-rw-r--r--security/isakmpd/Makefile4
-rw-r--r--security/snortsam/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index d039ca6bcb6e..3bf44d1f2db1 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -26,7 +26,6 @@ BUILD_DEPENDS+= keynote:${PORTSDIR}/security/keynote
.endif
USE_RC_SUBR= isakmpd
-WRKSRC= ${WRKDIR}/isakmpd
MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man LC_ALL=C
MAN5= isakmpd.conf.5 isakmpd.policy.5
@@ -41,6 +40,9 @@ OPENSSLINC?= /usr/include
OPENSSLLIB?= /usr/lib
MAKE_ENV+= OPENSSLINC="${OPENSSLINC}" OPENSSLLIB="${OPENSSLLIB}"
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-patch:
.for f in conf.h ike_auth.c isakmpd.8 isakmpd.conf.5 isakmpd.policy.5 policy.h
${REINPLACE_CMD} -e "s!/etc/!${PREFIX}/etc/!" ${WRKSRC}/${f}
diff --git a/security/snortsam/Makefile b/security/snortsam/Makefile
index 8baee38d07a6..14030bb3aba9 100644
--- a/security/snortsam/Makefile
+++ b/security/snortsam/Makefile
@@ -28,7 +28,6 @@ SUB_FILES= pkg-message \
HAS_CONFIGURE= yes
NO_BUILD= yes
CONFIGURE_SCRIPT= src/Makefile
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
CONFIG_DIR?= ${PREFIX}/etc/snortsam
@@ -55,6 +54,9 @@ EXTRA_PATCHES+= ${FILESDIR}/ssp_ipfw2_no_table_check.patch
DEBUG=-DDEBUG
.endif
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
pre-configure:
@${REINPLACE_CMD} -e "s|/etc/snortsam.conf|${CONFIG_DIR}/snortsam.conf|g" ${WRKSRC}/conf/snortsam.conf.sample
@${REINPLACE_CMD} -e "s|/etc/snortsam.conf|${CONFIG_DIR}/snortsam.conf|g" ${WRKSRC}/docs/README.conf