aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2012-06-02 11:26:33 +0800
committertj <tj@FreeBSD.org>2012-06-02 11:26:33 +0800
commitb4330e9690bf3d5dc91c588fa79142fe4e43d05f (patch)
treec1a0cddc4440df56c3ac91e468c8b185c84e3901 /security
parent14bb7d0e2f3d231e15bdd32214ae33ad4eda2aa3 (diff)
downloadfreebsd-ports-gnome-b4330e9690bf3d5dc91c588fa79142fe4e43d05f.tar.gz
freebsd-ports-gnome-b4330e9690bf3d5dc91c588fa79142fe4e43d05f.tar.zst
freebsd-ports-gnome-b4330e9690bf3d5dc91c588fa79142fe4e43d05f.zip
Convert to OptionsNG framework.
Approved by: eadler (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/lasso/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 061fa268b14c..851b4067506a 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -24,13 +24,11 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
-OPTIONS= PERL "Enable Perl Bindings" Off \
- PHP5 "Enable PHP5 Bindings" Off \
- PYTHON "Enable Python Bindings" Off
+OPTIONS_DEFINE= PERL PHP PYTHON
.include <bsd.port.options.mk>
-.ifdef(WITH_PERL)
+.if !empty(PORT_OPTIONS:MPERL)
CONFIGURE_ARGS+= --enable-perl
PLIST_SUB+= WITH_PERL=""
USE_PERL5= yes
@@ -39,7 +37,7 @@ CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= WITH_PERL="@comment "
.endif
-.ifdef(WITH_PHP5)
+.if !empty(PORT_OPTIONS:MPHP)
CONFIGURE_ARGS+= --enable-php5 \
--with-php5-config="${LOCALBASE}/bin/php-config"
IGNORE_WITH_PHP= 4
@@ -53,7 +51,7 @@ CONFIGURE_ARGS+= --disable-php5
PLIST_SUB+= WITH_PHP5="@comment "
.endif
-.ifdef(WITH_PYTHON)
+.if !empty(PORT_OPTIONS:MPYTHON)
CONFIGURE_ARGS+= --enable-python
PLIST_SUB+= WITH_PYTHON=""
USE_PYTHON= yes