aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwes <wes@FreeBSD.org>2000-03-10 09:22:54 +0800
committerwes <wes@FreeBSD.org>2000-03-10 09:22:54 +0800
commitb6e1cef9b70bfb9e9a5736183073e77d67d9f1bd (patch)
tree5db6f31f06ace6d252ea60dbc92a86ca60a0143e /security
parent61664367e13382e86787cce5e388fa50aeaf5461 (diff)
downloadfreebsd-ports-gnome-b6e1cef9b70bfb9e9a5736183073e77d67d9f1bd.tar.gz
freebsd-ports-gnome-b6e1cef9b70bfb9e9a5736183073e77d67d9f1bd.tar.zst
freebsd-ports-gnome-b6e1cef9b70bfb9e9a5736183073e77d67d9f1bd.zip
Port for Seahorse, a Gnome front end for GnuPG.
PR: 17295 Submitted by: Dave McKay <dave@elvis.mu.org> Obtained from: Dave McKay <dave@elvis.mu.org>
Diffstat (limited to 'security')
-rw-r--r--security/seahorse/Makefile27
-rw-r--r--security/seahorse/distinfo1
-rw-r--r--security/seahorse/pkg-comment1
-rw-r--r--security/seahorse/pkg-descr8
-rw-r--r--security/seahorse/pkg-plist1
5 files changed, 38 insertions, 0 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
new file mode 100644
index 000000000000..e7e4e4ec8990
--- /dev/null
+++ b/security/seahorse/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Seahorse
+# Version required: 0.3.6
+# Date created: 08 March 2000
+# Whom: Dave McKay <dave@mu.org>
+#
+# $FreeBSD$
+#
+#http://seahorse.sourceforge.net/
+
+DISTNAME= seahorse-0.3.6
+CATEGORIES= security
+MASTER_SITES= http://www.mu.org/~dave/
+
+MAINTAINER= dave@mu.org
+
+GNU_CONFIGURE= yes
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+RUN_DEPENDS= gnupg-1.0.1:${PORTSDIR}/security/gnupg
+MAN1= seahorse.1
+
+WRKSRC= ${WRKDIR}/seahorse-0.3.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/seahorse ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/seahorse.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/seahorse/distinfo b/security/seahorse/distinfo
new file mode 100644
index 000000000000..61e4d2578276
--- /dev/null
+++ b/security/seahorse/distinfo
@@ -0,0 +1 @@
+MD5 (seahorse-0.3.6.tar.gz) = 3ed6a930659d6d2e27ad3f4e55527779
diff --git a/security/seahorse/pkg-comment b/security/seahorse/pkg-comment
new file mode 100644
index 000000000000..46c6e4a40966
--- /dev/null
+++ b/security/seahorse/pkg-comment
@@ -0,0 +1 @@
+A front end for GnuPG.
diff --git a/security/seahorse/pkg-descr b/security/seahorse/pkg-descr
new file mode 100644
index 000000000000..27561c408b83
--- /dev/null
+++ b/security/seahorse/pkg-descr
@@ -0,0 +1,8 @@
+Seahorse is a Gnome front end for GnuPG - the Gnu Privacy Guard program.
+
+It is a tool for secure communications and data storage.
+Data encryption and digital signature creation can easily
+be performed through a GUI and Key Management operations
+can easily be carried out through an intuitive interface.
+
+http://seahorse.sourceforge.net/
diff --git a/security/seahorse/pkg-plist b/security/seahorse/pkg-plist
new file mode 100644
index 000000000000..c3c50b736daa
--- /dev/null
+++ b/security/seahorse/pkg-plist
@@ -0,0 +1 @@
+bin/seahorse