aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-05-08 18:45:09 +0800
committerantoine <antoine@FreeBSD.org>2013-05-08 18:45:09 +0800
commitc0ec88e9a9ab2773f3e4e495541fc9d9c45b2224 (patch)
tree1d80d3fb54324302e7fbb9b9809e0df2c08ace07 /security
parentd899a3e5649ca2d3b5763836c27a4e95aca0c3d0 (diff)
downloadfreebsd-ports-gnome-c0ec88e9a9ab2773f3e4e495541fc9d9c45b2224.tar.gz
freebsd-ports-gnome-c0ec88e9a9ab2773f3e4e495541fc9d9c45b2224.tar.zst
freebsd-ports-gnome-c0ec88e9a9ab2773f3e4e495541fc9d9c45b2224.zip
Use package names rather than files in PYTHON_SITELIBDIR for depends.
Requested by: rm Approved by: eadler, miwi (mentors, implicit)
Diffstat (limited to 'security')
-rw-r--r--security/py-plaso/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 0b61c6c6d5cf..462f182eeb1d 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -14,15 +14,15 @@ COMMENT= Automatic creation of a super timeline
LICENSE= AL2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/hachoir_core/__init__.py:${PORTSDIR}/devel/hachoir-core \
- ${PYTHON_SITELIBDIR}/hachoir_metadata/__init__.py:${PORTSDIR}/sysutils/hachoir-metadata \
- ${PYTHON_SITELIBDIR}/hachoir_parser/__init__.py:${PORTSDIR}/devel/hachoir-parser \
- ${PYTHON_SITELIBDIR}/pyevt.so:${PORTSDIR}/devel/libevt \
- ${PYTHON_SITELIBDIR}/pyevtx.so:${PORTSDIR}/devel/libevtx \
- ${PYTHON_SITELIBDIR}/pylnk.so:${PORTSDIR}/devel/liblnk \
- ${PYTHON_SITELIBDIR}/pymsiecf.so:${PORTSDIR}/devel/libmsiecf \
- ${PYTHON_SITELIBDIR}/pyregf.so:${PORTSDIR}/devel/libregf \
- ${PYTHON_SITELIBDIR}/pyvshadow.so:${PORTSDIR}/devel/libvshadow \
+RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
+ hachoir-metadata>=0:${PORTSDIR}/sysutils/hachoir-metadata \
+ hachoir-parser>=0:${PORTSDIR}/devel/hachoir-parser \
+ libevt>=a:${PORTSDIR}/devel/libevt \
+ libevtx>=a:${PORTSDIR}/devel/libevtx \
+ liblnk>=0:${PORTSDIR}/devel/liblnk \
+ libmsiecf>=a:${PORTSDIR}/devel/libmsiecf \
+ libregf>=a:${PORTSDIR}/devel/libregf \
+ libvshadow>=0:${PORTSDIR}/devel/libvshadow \
ipython${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/devel/ipython \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}protobuf>=0:${PORTSDIR}/devel/py-protobuf \