aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-06-27 01:21:51 +0800
committerpat <pat@FreeBSD.org>2002-06-27 01:21:51 +0800
commitc5f53c010d59e92c876dbf907ad3f58f22dd5d16 (patch)
tree4086bcca0d0d187a514a5618d07b54e1101fde16 /security
parentea7c55128b98cd92e98f81ee043634e004e0a722 (diff)
downloadfreebsd-ports-gnome-c5f53c010d59e92c876dbf907ad3f58f22dd5d16.tar.gz
freebsd-ports-gnome-c5f53c010d59e92c876dbf907ad3f58f22dd5d16.tar.zst
freebsd-ports-gnome-c5f53c010d59e92c876dbf907ad3f58f22dd5d16.zip
Add new port rc5pipe: RC5 en-/decryption via UNIX pipes
PR: ports/39880 Submitted by: Frerich Raabe <frerich.raabe@gmx.de>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rc5pipe/Makefile21
-rw-r--r--security/rc5pipe/distinfo1
-rw-r--r--security/rc5pipe/files/patch-Makefile11
-rw-r--r--security/rc5pipe/pkg-comment1
-rw-r--r--security/rc5pipe/pkg-descr6
-rw-r--r--security/rc5pipe/pkg-plist1
7 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d94f0a2da8c4..b2a3711b8331 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -215,6 +215,7 @@
SUBDIR += radiusniff
SUBDIR += rain
SUBDIR += rats
+ SUBDIR += rc5pipe
SUBDIR += rid
SUBDIR += rsaref
SUBDIR += ruby-acl
diff --git a/security/rc5pipe/Makefile b/security/rc5pipe/Makefile
new file mode 100644
index 000000000000..44c1df5febd3
--- /dev/null
+++ b/security/rc5pipe/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: rc5pipe
+# Date created: 25 June 2002
+# Whom: Frerich Raabe <frerich.raabe@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rc5pipe
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://krazykiwi.homeip.net/FreeBSD/ports/rc5pipe/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= frerich.raabe@gmx.de
+
+WRKSRC= ${WRKDIR}/rc5pipe
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rc5pipe ${PREFIX}/bin/rc5pipe
+
+.include <bsd.port.mk>
diff --git a/security/rc5pipe/distinfo b/security/rc5pipe/distinfo
new file mode 100644
index 000000000000..e3b32a92584c
--- /dev/null
+++ b/security/rc5pipe/distinfo
@@ -0,0 +1 @@
+MD5 (rc5pipe-1.1.tgz) = df7d4b5f1f74ed04060fce577acf637b
diff --git a/security/rc5pipe/files/patch-Makefile b/security/rc5pipe/files/patch-Makefile
new file mode 100644
index 000000000000..647cf93e542f
--- /dev/null
+++ b/security/rc5pipe/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Wed Jun 26 12:18:06 2002
++++ Makefile Wed Jun 26 12:18:32 2002
+@@ -1,6 +1,5 @@
+-CC=gcc
+-CFLAGS= -I/usr/local/include -s -O2
+-LIBS= -L/usr/local/lib
++CFLAGS+= -I${LOCALBASE}/include -s
++LIBS= -L${LOCALBASE}/lib
+
+ all:
+ $(CC) $(CFLAGS) -o rc5pipe rc5pipe.c $(LIBS)
diff --git a/security/rc5pipe/pkg-comment b/security/rc5pipe/pkg-comment
new file mode 100644
index 000000000000..23ab40147be0
--- /dev/null
+++ b/security/rc5pipe/pkg-comment
@@ -0,0 +1 @@
+RC5 en-/decryption via UNIX pipes
diff --git a/security/rc5pipe/pkg-descr b/security/rc5pipe/pkg-descr
new file mode 100644
index 000000000000..ff337d5c3206
--- /dev/null
+++ b/security/rc5pipe/pkg-descr
@@ -0,0 +1,6 @@
+rc5pipe is a security program for encrypting and decrypting text via UNIX
+pipes. It uses the 128-bit RC5 encryption algorithm and takes advantage of
+padding, and is especially useful if combined with netcat.
+
+- Frerich Raabe
+frerich.raabe@gmx.de
diff --git a/security/rc5pipe/pkg-plist b/security/rc5pipe/pkg-plist
new file mode 100644
index 000000000000..875d8b0558ea
--- /dev/null
+++ b/security/rc5pipe/pkg-plist
@@ -0,0 +1 @@
+bin/rc5pipe