aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 12:20:19 +0800
committermarino <marino@FreeBSD.org>2016-09-11 12:20:19 +0800
commitccd78b27a4e3a1f2bddf146a862909a9ffbd1ee6 (patch)
tree3b934ca637dd770260e4139483a241879d2a3b75 /security
parent1227da01fb0573b8f35f1605242e5cf206816f17 (diff)
downloadfreebsd-ports-gnome-ccd78b27a4e3a1f2bddf146a862909a9ffbd1ee6.tar.gz
freebsd-ports-gnome-ccd78b27a4e3a1f2bddf146a862909a9ffbd1ee6.tar.zst
freebsd-ports-gnome-ccd78b27a4e3a1f2bddf146a862909a9ffbd1ee6.zip
security/pam_ocra: Fix SSL handling especially wrt FreeBSD 9
The SSL flags were moved to show unconditionally as they are always correct. The WITH_OPENSSL_PORT=yes variable was replaced with an SSL version check so that the port is marked broken if built on FreeBSD 9 with the base OpenSSL libary selected. This fixes other values of SSL_DEFAULT on all platforms. Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/pam_ocra/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/security/pam_ocra/Makefile b/security/pam_ocra/Makefile
index 22134d709612..8eca95b265c8 100644
--- a/security/pam_ocra/Makefile
+++ b/security/pam_ocra/Makefile
@@ -10,25 +10,23 @@ COMMENT= RFC6287 (OCRA) PAM module
LICENSE= BSD2CLAUSE
-USES= uidfix
-USE_OPENSSL= yes
-
+USES= ssl uidfix
USE_GITHUB= yes
-
GH_ACCOUNT= sg2342
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
+
PLIST_FILES= lib/pam_ocra.so \
lib/pam_ocra.so.0 \
sbin/ocra_tool \
man/man8/pam_ocra.8.gz \
man/man8/ocra_tool.8.gz
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000015
-WITH_OPENSSL_PORT= yes
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
+.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>