aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2016-10-21 08:05:57 +0800
committerjhale <jhale@FreeBSD.org>2016-10-21 08:05:57 +0800
commitcfa75d069cfbfceeac3ef2672079a116c66e7861 (patch)
tree05719c2c2294baa3d13455ae36144ab9f10443f2 /security
parent2bd2eb012fd3db98381dd2869ce5a31acde2c435 (diff)
downloadfreebsd-ports-gnome-cfa75d069cfbfceeac3ef2672079a116c66e7861.tar.gz
freebsd-ports-gnome-cfa75d069cfbfceeac3ef2672079a116c66e7861.tar.zst
freebsd-ports-gnome-cfa75d069cfbfceeac3ef2672079a116c66e7861.zip
Really fix build on 9.x for the c++ and Qt5 bindings;
require libc++.
Diffstat (limited to 'security')
-rw-r--r--security/gpgme/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index e40ed1c50fcd..d69c811fec0d 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -87,6 +87,12 @@ CONFLICTS_INSTALL= py*-pyme-[0-9]*
.include <bsd.port.pre.mk>
.if defined(SLAVEPORT)
+. if (${SLAVEPORT} == "cpp" || ${SLAVEPORT} == "qt5")
+. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
+BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
+CXXFLAGS+= -stdlib=libc++ -I${LOCALBASE}/include/c++/v1
+. endif
+. endif
. if ${SLAVEPORT} == "python"
. if ${PYTHON_REL} >= 3000
CONFIGURE_ARGS+=--enable-languages="python3"