aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-05-08 04:04:49 +0800
committerdinoex <dinoex@FreeBSD.org>2003-05-08 04:04:49 +0800
commitd53a3e842dc0cb2c02b2c48c36520dde3b8f9e31 (patch)
tree41e46a698dcb01aefc3e960a4be107ba9ee6e7f9 /security
parent4ba7b9fe60d136a0c1c8a2e3fdb0a28f39579213 (diff)
downloadfreebsd-ports-gnome-d53a3e842dc0cb2c02b2c48c36520dde3b8f9e31.tar.gz
freebsd-ports-gnome-d53a3e842dc0cb2c02b2c48c36520dde3b8f9e31.tar.zst
freebsd-ports-gnome-d53a3e842dc0cb2c02b2c48c36520dde3b8f9e31.zip
- Update to gssapi-20030430
Submitted by: wollman@lcs.mit.edu
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/Makefile19
-rw-r--r--security/hpn-ssh/distinfo1
-rw-r--r--security/openssh-portable/Makefile19
-rw-r--r--security/openssh-portable/distinfo1
4 files changed, 24 insertions, 16 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 593d52c7551f..7b6b7b32fad5 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -79,19 +79,17 @@ post-extract:
.endfor
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-BROKEN= patch conflicts with 3.5p1
PKGNAMESUFFIX= -gssapi
-GSSAPI_PATCH= ${PORTNAME}-3.4p1-gssapi-20020627.diff
+GSSAPI_PATCH= ${PORTNAME}-3.6.1p2-gssapi-20030430.diff
GSSAPI_SITE= http://www.sxw.org.uk/computing/patches/
MASTER_SITES+= ${GSSAPI_SITE}
DISTFILES= ${EXTRACT_ONLY} ${GSSAPI_PATCH}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
EXTRA_PATCHES+= ${FILESDIR}/servconf.c.patch
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+BUILD_DEPENDS+= autoreconf:${PORTSDIR}/devel/autoconf
# USE_AUTOCONF_VER= 252 # broken
CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-AUTOCONF= autoconf
-AUTOHEADER= autoheader
+AUTORECONF= autoreconf
post-patch:
@${ECHO_MSG} Applying extra patch for GSS-API key-exchange...
@@ -99,10 +97,9 @@ post-patch:
< ${DISTDIR}/${GSSAPI_PATCH}
pre-configure:
- @${ECHO_MSG} !!!! Warning this option uses autoconf/autoheader !!!
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ @${ECHO_MSG} !!!! Warning this option uses autoreconf !!!
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTORECONF} \
${AUTOCONF_ARGS})
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
.endif
post-configure:
@@ -143,6 +140,12 @@ test:
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if ${OPENSSLBASE} == "/usr"
+CONFIGURE_ARGS+= --without-rpath
+LDFLAGS=
+.endif
+.endif
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}
.include <bsd.port.post.mk>
diff --git a/security/hpn-ssh/distinfo b/security/hpn-ssh/distinfo
index 716bdd274525..3a548c2820e2 100644
--- a/security/hpn-ssh/distinfo
+++ b/security/hpn-ssh/distinfo
@@ -1 +1,2 @@
MD5 (openssh-3.6.1p2.tar.gz) = f3879270bffe479e1bd057aa36258696
+MD5 (openssh-3.6.1p2-gssapi-20030430.diff) = 520e15f541398efed2763aaf8ac08e6a
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 593d52c7551f..7b6b7b32fad5 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -79,19 +79,17 @@ post-extract:
.endfor
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-BROKEN= patch conflicts with 3.5p1
PKGNAMESUFFIX= -gssapi
-GSSAPI_PATCH= ${PORTNAME}-3.4p1-gssapi-20020627.diff
+GSSAPI_PATCH= ${PORTNAME}-3.6.1p2-gssapi-20030430.diff
GSSAPI_SITE= http://www.sxw.org.uk/computing/patches/
MASTER_SITES+= ${GSSAPI_SITE}
DISTFILES= ${EXTRACT_ONLY} ${GSSAPI_PATCH}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
EXTRA_PATCHES+= ${FILESDIR}/servconf.c.patch
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+BUILD_DEPENDS+= autoreconf:${PORTSDIR}/devel/autoconf
# USE_AUTOCONF_VER= 252 # broken
CONFIGURE_ARGS+= --with-kerberos5=${KRB5_HOME}
-AUTOCONF= autoconf
-AUTOHEADER= autoheader
+AUTORECONF= autoreconf
post-patch:
@${ECHO_MSG} Applying extra patch for GSS-API key-exchange...
@@ -99,10 +97,9 @@ post-patch:
< ${DISTDIR}/${GSSAPI_PATCH}
pre-configure:
- @${ECHO_MSG} !!!! Warning this option uses autoconf/autoheader !!!
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOCONF} \
+ @${ECHO_MSG} !!!! Warning this option uses autoreconf !!!
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTORECONF} \
${AUTOCONF_ARGS})
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOCONF_ENV} ${AUTOHEADER})
.endif
post-configure:
@@ -143,6 +140,12 @@ test:
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
+.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if ${OPENSSLBASE} == "/usr"
+CONFIGURE_ARGS+= --without-rpath
+LDFLAGS=
+.endif
+.endif
CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLBASE}
.include <bsd.port.post.mk>
diff --git a/security/openssh-portable/distinfo b/security/openssh-portable/distinfo
index 716bdd274525..3a548c2820e2 100644
--- a/security/openssh-portable/distinfo
+++ b/security/openssh-portable/distinfo
@@ -1 +1,2 @@
MD5 (openssh-3.6.1p2.tar.gz) = f3879270bffe479e1bd057aa36258696
+MD5 (openssh-3.6.1p2-gssapi-20030430.diff) = 520e15f541398efed2763aaf8ac08e6a