aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2003-09-01 18:44:42 +0800
committerume <ume@FreeBSD.org>2003-09-01 18:44:42 +0800
commitea6ca9a2e98eb0b336e095ed91df61e786701f6e (patch)
tree818faa8a4bf5d6a341d4a162c5da51c27319a87a /security
parent6ba134180825915c528b5b93a0a44de706462352 (diff)
downloadfreebsd-ports-gnome-ea6ca9a2e98eb0b336e095ed91df61e786701f6e.tar.gz
freebsd-ports-gnome-ea6ca9a2e98eb0b336e095ed91df61e786701f6e.tar.zst
freebsd-ports-gnome-ea6ca9a2e98eb0b336e095ed91df61e786701f6e.zip
USE_OPENSSL must be set before including bsd.port.pre.mk.
Reported by: Fritz Heinrichmeyer <Fritz.Heinrichmeyer@Fernuni-Hagen.de>
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile7
-rw-r--r--security/cyrus-sasl2/Makefile7
2 files changed, 4 insertions, 10 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index eae84c6999f2..a43e8ee4f942 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -29,6 +29,7 @@ DOCSDIR= ${PREFIX}/share/doc/cyrus-sasl2
USE_RC_SUBR= YES
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -39,6 +40,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -101,11 +103,6 @@ CONFIGURE_ARGS+=--enable-krb4=${LOCALBASE}/krb4
CONFIGURE_ARGS+=--disable-krb4
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index b1efaae1498c..ab76327eca44 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -38,6 +38,7 @@ MAN3= sasl.3 sasl_authorize_t.3 sasl_auxprop.3 \
sasl_user_exists.3 sasl_verifyfile_t.3
MAN8= sasldblistusers2.8 saslpasswd2.8
+USE_OPENSSL= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
@@ -48,6 +49,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--enable-static \
--enable-login \
--enable-auth-sasldb \
+ --with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
--with-saslauthd
@@ -142,11 +144,6 @@ CONFIGURE_ARGS+=--disable-krb4
EBONES= "@comment "
.endif
-USE_OPENSSL= yes
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
CONFIGURE_ENV+= LOCALBASE=${LOCALBASE} \
OPENSSLINC=${OPENSSLINC} \
OPENSSLLIB=${OPENSSLLIB} \