aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2012-05-12 04:38:09 +0800
committerade <ade@FreeBSD.org>2012-05-12 04:38:09 +0800
commitec81fd924ccfa4a135be31e8f27887286828c2de (patch)
treec4bd2f8529e840fa116e09d1f68e442cc7f2ce0c /security
parent497d7e487cb4abc3d85b201fc1bd72c134effbd4 (diff)
downloadfreebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.tar.gz
freebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.tar.zst
freebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.zip
Update autoconf to 2.69 and automake to 1.12
PR: 166836 Tested by: Multiple -exp runs (pav)
Diffstat (limited to 'security')
-rw-r--r--security/kovpn/Makefile2
-rw-r--r--security/kovpn/files/patch-admin-cvs.sh15
-rw-r--r--security/sssd/Makefile3
-rw-r--r--security/suricata/Makefile5
4 files changed, 20 insertions, 5 deletions
diff --git a/security/kovpn/Makefile b/security/kovpn/Makefile
index a47c13a66baf..941030b1f066 100644
--- a/security/kovpn/Makefile
+++ b/security/kovpn/Makefile
@@ -29,6 +29,8 @@ USE_XORG= xpm
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
+AUTOTOOLSFILES= admin/cvs.sh
+
.include <bsd.port.pre.mk>
pre-configure:
diff --git a/security/kovpn/files/patch-admin-cvs.sh b/security/kovpn/files/patch-admin-cvs.sh
index e8b9f5e70eba..39fcd3ad1409 100644
--- a/security/kovpn/files/patch-admin-cvs.sh
+++ b/security/kovpn/files/patch-admin-cvs.sh
@@ -1,7 +1,12 @@
---- admin/cvs.sh.orig 2008-07-07 15:38:56.000000000 -0500
-+++ admin/cvs.sh 2010-10-02 14:54:47.000000000 -0500
-@@ -70,3 +70,3 @@
- ;;
+--- admin/cvs.sh.orig 2008-07-07 13:38:56.000000000 -0700
++++ admin/cvs.sh 2012-04-24 09:34:37.000000000 -0700
+@@ -65,8 +65,3 @@
+ case $AUTOMAKE_STRING in
+- automake*1.5d* | automake*1.5* | automake*1.5-* )
+- echo "*** YOU'RE USING $AUTOMAKE_STRING."
+- echo "*** KDE requires automake $required_automake_version"
+- exit 1
+- ;;
- automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10*)
-+ automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10* | automake*1.11* )
++ automake*%%AUTOMAKE_VERSION%%* )
echo "*** $AUTOMAKE_STRING found."
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 47ba3479b52d..0e5e25c7aff6 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -74,7 +74,10 @@ IGNORE= is not supported prior to 8.0-RELEASE
BROKEN= Does not link on ia64, powerpc, or sparc64
.endif
+AUTOTOOLSFILES= aclocal.m4
+
post-patch:
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e 's|SIGCLD|SIGCHLD|g' ${WRKSRC}/src/util/signal.c
@${REINPLACE_CMD} -e '/#define SIZE_T_MAX ((size_t) -1)/d' ${WRKSRC}/src/util/util.h
@${REINPLACE_CMD} -e '/pam_misc/d' ${WRKSRC}/src/sss_client/pam_test_client.c
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 5e287cc8679e..fba36c4c3621 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -87,8 +87,13 @@ CONFIGURE_ARGS+= --enable-dag \
--with-dag-libraries=${LOCALBASE}/lib
.endif
+AUTOTOOLSFILES= aclocal.m4 libhtp/aclocal.m4
+
post-patch:
@${REINPLACE_CMD} -Ee 's|^(install-data-am: )install-pkgconfigDATA|\1|' ${WRKSRC}/libhtp/Makefile.in
+.for f in ${AUTOTOOLSFILES}
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' ${WRKSRC}/${f}
+.endfor
pre-install:
@${REINPLACE_CMD} -e 's|/etc/suricata|${PREFIX}/etc/suricata|g' ${WRKSRC}/suricata.yaml