aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-07-12 11:04:22 +0800
committermiwi <miwi@FreeBSD.org>2010-07-12 11:04:22 +0800
commiteea1553092dfae191f9098f94fd4ab512aada24e (patch)
treee3b2757bc9770a34f22559d948b25d368787a324 /security
parenta6ec4bef3013c077b30dd67440b7ffe6494654ec (diff)
downloadfreebsd-ports-gnome-eea1553092dfae191f9098f94fd4ab512aada24e.tar.gz
freebsd-ports-gnome-eea1553092dfae191f9098f94fd4ab512aada24e.tar.zst
freebsd-ports-gnome-eea1553092dfae191f9098f94fd4ab512aada24e.zip
- Update to 1.5.3
- Pass maintainership to submitter PR: 147833 Submitted by: Chris Rees <utisoft@gmail.com>
Diffstat (limited to 'security')
-rw-r--r--security/gorilla/Makefile30
-rw-r--r--security/gorilla/distinfo6
-rw-r--r--security/gorilla/files/gorilla.in10
-rw-r--r--security/gorilla/files/patch-gorilla.in8
-rw-r--r--security/gorilla/pkg-descr2
-rw-r--r--security/gorilla/pkg-plist1
6 files changed, 32 insertions, 25 deletions
diff --git a/security/gorilla/Makefile b/security/gorilla/Makefile
index 5c9cf7f26e99..26a6ef32859e 100644
--- a/security/gorilla/Makefile
+++ b/security/gorilla/Makefile
@@ -6,28 +6,32 @@
#
PORTNAME= gorilla
-PORTVERSION= 1.4
-PORTREVISION= 4
+PORTVERSION= 1.5.3
+DISTVERSIONSUFFIX= 1996106
CATEGORIES= security
-MASTER_SITES= http://www.fpx.de/fp/Software/Gorilla/download/
+MASTER_SITES= http://download.github.com/\
+ http://www.bayofrum.net/dist/gorilla/
+DISTNAME= zdia-${PORTNAME}-v${DISTVERSION}-0-g${DISTVERSIONSUFFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Password Gorilla is cross-platform Password Manager
+MAINTAINER= utisoft@gmail.com
+COMMENT= Password Gorilla is a cross-platform Password Manager
-LIB_DEPENDS= itcl.3:${PORTSDIR}/lang/itcl
-RUN_DEPENDS= ${LOCALBASE}/lib/bwidget/init.tcl:${PORTSDIR}/x11-toolkits/bwidget
+RUN_DEPENDS= ${LOCALBASE}/lib/bwidget/init.tcl:${PORTSDIR}/x11-toolkits/bwidget \
+ itcl>=3.4:${PORTSDIR}/lang/itcl
-USE_TCL_RUN= 84
-USE_TK= 84
-GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/zdia-${PORTNAME}-${DISTVERSIONSUFFIX}
+USE_TCL_RUN= 85+
+USE_TK= 85+
NO_BUILD= yes
+SUB_FILES= gorilla
+SUB_LIST= WISH=wish
do-install:
@${MKDIR} ${PREFIX}/lib/gorilla
- @${INSTALL_SCRIPT} ${WRKSRC}/*.tcl ${PREFIX}/lib/gorilla
- ${TAR} -C ${WRKSRC} -cf - blowfish pics pwsafe twofish sha1 | \
+ @${INSTALL_SCRIPT} ${WRKSRC}/sources/*.tcl ${PREFIX}/lib/gorilla
+ ${TAR} -C ${WRKSRC}/sources -cf - blowfish pics pwsafe twofish sha1 | \
${TAR} -C ${PREFIX}/lib/gorilla --unlink -xf -
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
post-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/gorilla
diff --git a/security/gorilla/distinfo b/security/gorilla/distinfo
index 5c90a2ffdf83..7b3b285e520a 100644
--- a/security/gorilla/distinfo
+++ b/security/gorilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (gorilla-1.4.tar.gz) = 9914efa3ddaf309de76f083c43f57dce
-SHA256 (gorilla-1.4.tar.gz) = 3184ff802d0f96250302e2ce1a966d5eca328e8e0becc44e037208af32ee0551
-SIZE (gorilla-1.4.tar.gz) = 190766
+MD5 (zdia-gorilla-v1.5.3-0-g1996106.tar.gz) = 441f7599e758fe83b942d812f3c5414a
+SHA256 (zdia-gorilla-v1.5.3-0-g1996106.tar.gz) = cbb9d7c4af96b29a9337df4311853b9df5427aa3ff0b4c1e51b11d1471b1e580
+SIZE (zdia-gorilla-v1.5.3-0-g1996106.tar.gz) = 350166
diff --git a/security/gorilla/files/gorilla.in b/security/gorilla/files/gorilla.in
new file mode 100644
index 000000000000..e445bfd69af7
--- /dev/null
+++ b/security/gorilla/files/gorilla.in
@@ -0,0 +1,10 @@
+#! /bin/sh
+# the next line restarts using wish \
+exec %%WISH%% "$0" ${1+"$@"}
+set myName [info script]
+if {![catch {
+ set linkName [file readlink $myName]
+}]} {
+ set myName $linkName
+}
+source [file join [file dirname $myName] %%PREFIX%%/lib/gorilla/gorilla.tcl]
diff --git a/security/gorilla/files/patch-gorilla.in b/security/gorilla/files/patch-gorilla.in
deleted file mode 100644
index 9cabdc5c4d80..000000000000
--- a/security/gorilla/files/patch-gorilla.in
+++ /dev/null
@@ -1,8 +0,0 @@
---- gorilla.in.orig Sun Dec 5 22:21:54 2004
-+++ gorilla.in Sat Feb 11 12:30:44 2006
-@@ -7,4 +7,4 @@
- }]} {
- set myName $linkName
- }
--source [file join [file dirname $myName] gorilla.tcl]
-+source [file join [file dirname $myName] @prefix@/lib/gorilla/gorilla.tcl]
diff --git a/security/gorilla/pkg-descr b/security/gorilla/pkg-descr
index 4822b086599d..68e5fcb6cb79 100644
--- a/security/gorilla/pkg-descr
+++ b/security/gorilla/pkg-descr
@@ -2,4 +2,4 @@ Password Gorilla is cross-platform Password Manager. It is
compatible with "Password Safe" from Windows.
It uses TCL/Tk and runs on most platforms supported by Tcl/Tk.
-WWW: http://www.fpx.de/fp/Software/Gorilla
+WWW: http://github.com/zdia/gorilla
diff --git a/security/gorilla/pkg-plist b/security/gorilla/pkg-plist
index ecb949bbb984..4a6ddfc245d8 100644
--- a/security/gorilla/pkg-plist
+++ b/security/gorilla/pkg-plist
@@ -6,6 +6,7 @@ lib/gorilla/blowfish/LICENSE.txt
lib/gorilla/blowfish/blowfish.tcl
lib/gorilla/blowfish/blowtest.tcl
lib/gorilla/blowfish/pkgIndex.tcl
+lib/gorilla/pics/browse.gif
lib/gorilla/pics/gorilla-16x16.gif
lib/gorilla/pics/gorilla-32x32.gif
lib/gorilla/pics/gorilla-48x48.gif