aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-04-30 02:44:48 +0800
committerjohans <johans@FreeBSD.org>2013-04-30 02:44:48 +0800
commitefc2d6c89612b58ed4937f1a7d15eff276c9a5e7 (patch)
tree3d559c0ff9b90b935c8b0cadd819de14ef2cd3c2 /security
parent83e9e7495979de2cfb501bf3735e889d71019939 (diff)
downloadfreebsd-ports-gnome-efc2d6c89612b58ed4937f1a7d15eff276c9a5e7.tar.gz
freebsd-ports-gnome-efc2d6c89612b58ed4937f1a7d15eff276c9a5e7.tar.zst
freebsd-ports-gnome-efc2d6c89612b58ed4937f1a7d15eff276c9a5e7.zip
Update Nettle to 2.7
Diffstat (limited to 'security')
-rw-r--r--security/nettle/Makefile11
-rw-r--r--security/nettle/distinfo4
-rw-r--r--security/nettle/pkg-plist33
3 files changed, 13 insertions, 35 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 801f04d008cc..b045af08fe4f 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nettle
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU} \
http://www.lysator.liu.se/~nisse/archive/:liu \
@@ -28,9 +28,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-DOCS= NEWS README TODO nettle.html nettle.pdf
-EXAMPLES= examples/*.c examples/*.h
-
+PORTDOCS= NEWS README TODO nettle.html nettle.pdf
+PORTEXAMPLES= *.c *.h
INFO= nettle
.include <bsd.port.pre.mk>
@@ -44,11 +43,11 @@ CONFIGURE_ENV+= CCPIC=-fPIC
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} examples/${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index 66a9f6ed8916..d73bfac6a0e0 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nettle-2.6.tar.gz) = 60df624f63b997c832cae29f48ab9ada99df815bcd60d231526b83e786b4b156
-SIZE (nettle-2.6.tar.gz) = 1385695
+SHA256 (nettle-2.7.tar.gz) = c294ea133c05382cc2effb1734d49f4abeb1ad8515543a333de49a11422cd4d6
+SIZE (nettle-2.7.tar.gz) = 1557615
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index 941b02824cc6..b864cf8c44f6 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -18,6 +18,9 @@ include/nettle/ctr.h
include/nettle/des-compat.h
include/nettle/des.h
include/nettle/dsa.h
+include/nettle/ecc-curve.h
+include/nettle/ecc.h
+include/nettle/ecdsa.h
include/nettle/gcm.h
include/nettle/gosthash94.h
include/nettle/hmac.h
@@ -46,40 +49,16 @@ include/nettle/sha1.h
include/nettle/sha2.h
include/nettle/sha3.h
include/nettle/twofish.h
+include/nettle/umac.h
include/nettle/yarrow.h
lib/libhogweed.a
lib/libhogweed.so
lib/libhogweed.so.2
-lib/libhogweed.so.2.3
+lib/libhogweed.so.2.4
lib/libnettle.a
lib/libnettle.so
lib/libnettle.so.4
-lib/libnettle.so.4.5
+lib/libnettle.so.4.6
libdata/pkgconfig/nettle.pc
libdata/pkgconfig/hogweed.pc
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/nettle.html
-%%PORTDOCS%%%%DOCSDIR%%/nettle.pdf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16dec.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16enc.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64dec.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64enc.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eratosthenes.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-benchmark.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-openssl.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/next-prime.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/random-prime.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read_rsa_key.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-decrypt.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-encrypt.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-keygen.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-session.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-sign.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-verify.c
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/nettle