aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-04-30 14:28:27 +0800
committerjgh <jgh@FreeBSD.org>2013-04-30 14:28:27 +0800
commitf295e054a260dfe63b0118e593f9c0ca548a52df (patch)
tree9ac8f69fd2dfd45c6681e387401491b9bfe89ed8 /security
parent01caedcbcc0dfdc057c7f11d56cbb949ba1cf620 (diff)
downloadfreebsd-ports-gnome-f295e054a260dfe63b0118e593f9c0ca548a52df.tar.gz
freebsd-ports-gnome-f295e054a260dfe63b0118e593f9c0ca548a52df.tar.zst
freebsd-ports-gnome-f295e054a260dfe63b0118e593f9c0ca548a52df.zip
- convert ports to USES= gettext
Approved by: portmgr (bapt@)
Diffstat (limited to 'security')
-rw-r--r--security/gnupg1/Makefile2
-rw-r--r--security/gnutls-devel/Makefile6
-rw-r--r--security/gpa/Makefile12
-rw-r--r--security/yapet/Makefile8
4 files changed, 14 insertions, 14 deletions
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index 3d120fe1c0bc..c3bf31cfd480 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -67,7 +67,7 @@ CONFIGURE_ARGS+= --disable-ldap
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= YES
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index 158ea23b4d98..57a5577a8080 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+= --disable-guile --disable-silent-rules \
--disable-hardware-acceleration
MANCOMPRESSED= no
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.5)) && !defined(WITHOUT_LIBTASN1)
LIB_DEPENDS+= tasn1.5:${PORTSDIR}/security/libtasn1
@@ -54,7 +54,7 @@ PLIST_SUB+= CXX=""
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
@@ -80,4 +80,4 @@ post-install:
.endif
.include "Makefile.man"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/gpa/Makefile b/security/gpa/Makefile
index cba48511390f..86e4aac45f25 100644
--- a/security/gpa/Makefile
+++ b/security/gpa/Makefile
@@ -32,18 +32,18 @@ MAN1= gpa.1
OPTIONS_DEFINE= NLS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !exists(${LOCALBASE}/bin/gpgsm)
IGNORE= requires gpgsm. (Re)Install security/gnupg with the GPGSM option ON, then rebuild security/gpgme if installed
.endif
-.if empty(PORT_OPTIONS:MNLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/yapet/Makefile b/security/yapet/Makefile
index 65120d8d7ed0..e0b4c77513a5 100644
--- a/security/yapet/Makefile
+++ b/security/yapet/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= security
MASTER_SITES= http://www.guengel.ch/myapps/yapet/downloads/ http://homepage.hispeed.ch/rostertag/yapet/
MAINTAINER= rafi@guengel.ch
-COMMENT= A curses based password manager
+COMMENT= Curses based password manager
MAN1= yapet.1
MANCOMPRESSED= no
@@ -21,7 +21,7 @@ TTITLE_DESC= Enable Terminal Title
PWGEN_DESC= Enable Password Generator
CSV2YAPET_DESC= Build csv2yapet
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# --enable-silent-rules: will make the build quiet
# --disable-install-doc: I take care of installing docs
@@ -49,7 +49,7 @@ PLIST_SUB+= CSV2YAPET="@comment "
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
@@ -77,4 +77,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/THANKS ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>