aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-07-25 05:22:58 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-07-25 05:22:58 +0800
commit07937bb28cbeb86fa6939d4b72de12c9300e8ded (patch)
treea2b220f799e02ccd1dd841414f21101a728bdff5 /security
parent781938eced715d8aecf0edfaaedbbc6b4b95dae6 (diff)
downloadfreebsd-ports-gnome-07937bb28cbeb86fa6939d4b72de12c9300e8ded.tar.gz
freebsd-ports-gnome-07937bb28cbeb86fa6939d4b72de12c9300e8ded.tar.zst
freebsd-ports-gnome-07937bb28cbeb86fa6939d4b72de12c9300e8ded.zip
security/letskencrypt: Update to 0.1.9
- Update to latest release - Fix staging issue, MAKE_ARGS to MAKE_ENV - Fix shebang problem in periodic script [1] - Update SSL_DEFAULT check PR: 210772 [1]
Diffstat (limited to 'security')
-rw-r--r--security/letskencrypt/Makefile21
-rw-r--r--security/letskencrypt/distinfo6
-rw-r--r--security/letskencrypt/files/000.letskencrypt.sh.in2
3 files changed, 14 insertions, 15 deletions
diff --git a/security/letskencrypt/Makefile b/security/letskencrypt/Makefile
index 766f79d62699..d0f952d6eddf 100644
--- a/security/letskencrypt/Makefile
+++ b/security/letskencrypt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= letskencrypt
-PORTVERSION= 0.1.7
+PORTVERSION= 0.1.9
DISTVERSIONPREFIX= portable-
CATEGORIES= security
MASTER_SITES= https://kristaps.bsd.lv/letskencrypt/snapshots/ \
@@ -16,16 +16,16 @@ LICENSE= ISCL
USES= gmake ssl tar:tgz
MAKEFILE= GNUmakefile
-MAKE_ARGS= PREFIX=${STAGEDIR}/${PREFIX}
+MAKE_ENV= PREFIX=${STAGEDIR}/${PREFIX}
WWWDIR= ${PREFIX}/www/letsencrypt
SAMPLE_FILES= letskencrypt.sh.sample deploy.sh.sample
SUB_FILES= 000.letskencrypt.sh pkg-message ${SAMPLE_FILES}
-SUB_LIST= PORTNAME=${PORTNAME}
+SUB_LIST= PORTNAME=${PORTNAME}
-PERIODIC_DIRS= etc/periodic/weekly
-PERIODIC_FILES= 000.letskencrypt.sh
+PERIODIC_DIRS= etc/periodic/weekly
+PERIODIC_FILES= 000.letskencrypt.sh
post-patch:
${REINPLACE_CMD} -e "s|/etc/|${PREFIX}/etc/|" \
@@ -33,13 +33,11 @@ post-patch:
${WRKSRC}/main.c ${WRKSRC}/letskencrypt.1
post-install:
- ${MKDIR} -p ${STAGEDIR}${PREFIX}/${PERIODIC_DIRS}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${PERIODIC_DIRS}
${INSTALL_SCRIPT} ${WRKDIR}/${PERIODIC_FILES} ${STAGEDIR}${PREFIX}/${PERIODIC_DIRS}/${PERIODIC_FILES}
-
-post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/letskencrypt
. for d in etc/ssl/letsencrypt etc/ssl/letsencrypt/private \
- etc/letsencrypt www/letsencrypt
+ etc/letsencrypt www/letsencrypt
${MKDIR} ${STAGEDIR}${PREFIX}/${d}
. endfor
. for d in ${SAMPLE_FILES}
@@ -48,8 +46,9 @@ post-stage:
.include <bsd.port.pre.mk>
-.if empty(SSL_DEFAULT:Mlibressl*)
-IGNORE= Need LibreSSL to build. set DEFAULT_VERSIONS+=ssl=libressl and rebuild everything.
+.if empty(SSL_DEFAULT:M*libressl*)
+IGNORE= needs LibreSSL to build. set DEFAULT_VERSIONS+=ssl=libressl \
+ and rebuild all ports that depend on openssl
.endif
.include <bsd.port.post.mk>
diff --git a/security/letskencrypt/distinfo b/security/letskencrypt/distinfo
index f1b62ce92928..535c2a523864 100644
--- a/security/letskencrypt/distinfo
+++ b/security/letskencrypt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467232311
-SHA256 (letskencrypt-portable-0.1.7.tgz) = 18b32f68f76c0e1d0e61b87d7fcabbcc6247fe824f16b707fa9370b4912b9da9
-SIZE (letskencrypt-portable-0.1.7.tgz) = 40243
+TIMESTAMP = 1469391913
+SHA256 (letskencrypt-portable-0.1.9.tgz) = e3c287998ec624dca28ea616e3df98fe87860eb4490f7f8fff931f38f9d94c02
+SIZE (letskencrypt-portable-0.1.9.tgz) = 41285
diff --git a/security/letskencrypt/files/000.letskencrypt.sh.in b/security/letskencrypt/files/000.letskencrypt.sh.in
index 24c2d208807c..a5713a18389b 100644
--- a/security/letskencrypt/files/000.letskencrypt.sh.in
+++ b/security/letskencrypt/files/000.letskencrypt.sh.in
@@ -1,4 +1,4 @@
-#/bin/sh
+#!/bin/sh
if [ -r /etc/defaults/periodic.conf ]
then