aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2003-02-10 21:21:21 +0800
committermarkp <markp@FreeBSD.org>2003-02-10 21:21:21 +0800
commit08b11f16c7fe0b3d1baf8c89405ef91df773cf39 (patch)
treeb2f82ac1f744af64e50832519a2ae33ff96ddfe1 /security
parentcb6b357005e8ed6d35d1e29d02f0fbf2eddc72c1 (diff)
downloadfreebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.tar.gz
freebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.tar.zst
freebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.zip
Changed to use REINPLACE.
Diffstat (limited to 'security')
-rw-r--r--security/stegdetect/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index 1c5f3e552ec6..ebdf27c1e71d 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
# Note: stegdetect includes a modified version of jpeg-6b linked statically
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_REINPLACE= yes
MAN1= stegdetect.1 stegbreak.1
.if defined(WITHOUT_X11)
@@ -32,10 +33,10 @@ PLIST_SUB+= X11=""
.endif
post-patch:
- @${PERL} -pi -e 's@\$$\(JPEGLIB\)@\$$\(JPEGLIB\) \-lcrypto@' \
+ ${REINPLACE_CMD} 's/$$(JPEGLIB)/$$(JPEGLIB) -lcrypto/' \
${WRKSRC}/Makefile.in
.if defined(WITHOUT_X11)
- @${PERL} -pi -e 's/gtk-config//g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's/gtk-config//g' ${WRKSRC}/configure
.endif
.include <bsd.port.mk>