aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
commit0a710f368469e3e4eae0e43e8df218c8a9983268 (patch)
treef1130d11cb235986af009fc8b05aa63a6548dcdd /security
parentba25a6ecc79a73710fb284c6682d27fad65d1d0e (diff)
downloadfreebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.gz
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.zst
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.zip
- Update The Glorious Glasgow Haskell Compiler to version 7.4.1
Please note that port revision for all the Haskell ports without version changes are also bumped. Other per-port updates are coming soon (in separate commits)! In addition to that, separate -docs ports are no longer needed so they are now removed. Thanks ashish@ for the assistance. Obtained from: FreeBSD Haskell
Diffstat (limited to 'security')
-rw-r--r--security/Makefile2
-rw-r--r--security/hs-cprng-aes/Makefile4
-rw-r--r--security/hs-entropy/Makefile1
-rw-r--r--security/hs-pureMD5/Makefile3
-rw-r--r--security/hs-pwstore-fast/Makefile3
5 files changed, 10 insertions, 3 deletions
diff --git a/security/Makefile b/security/Makefile
index 2591ddd58c07..8034439cc70f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -198,6 +198,8 @@
SUBDIR += hs-cryptohash
SUBDIR += hs-digest
SUBDIR += hs-entropy
+ SUBDIR += hs-monadcryptorandom
+ SUBDIR += hs-pem
SUBDIR += hs-pureMD5
SUBDIR += hs-pwstore-fast
SUBDIR += hs-skein
diff --git a/security/hs-cprng-aes/Makefile b/security/hs-cprng-aes/Makefile
index 69cd7c61bde7..c4b38b81be8f 100644
--- a/security/hs-cprng-aes/Makefile
+++ b/security/hs-cprng-aes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cprng-aes
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +16,8 @@ COMMENT= Crypto Pseudo Random Number Generator using AES
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= cereal>=0.3.0 crypto-api>=0.8 cryptocipher>=0.2.5 entropy>=0.2
+USE_CABAL= cereal>=0.3.0 crypto-api>=0.8 cryptocipher>=0.2.5 entropy>=0.2 \
+ random
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-entropy/Makefile b/security/hs-entropy/Makefile
index 1b5a8359f011..3b4ad0784c09 100644
--- a/security/hs-entropy/Makefile
+++ b/security/hs-entropy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= entropy
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/security/hs-pureMD5/Makefile b/security/hs-pureMD5/Makefile
index fc8e9a3d4aec..befcc5457e20 100644
--- a/security/hs-pureMD5/Makefile
+++ b/security/hs-pureMD5/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pureMD5
PORTVERSION= 2.1.0.3
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -14,7 +15,7 @@ COMMENT= Haskell implementation of MD5 algorithm
LICENSE= BSD
-USE_CABAL= binary>=0.4.0 cereal>=0.2 crypto-api tagged
+USE_CABAL= cereal>=0.2 crypto-api tagged
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/security/hs-pwstore-fast/Makefile b/security/hs-pwstore-fast/Makefile
index ebdc12f09ddc..5fdf0f13df28 100644
--- a/security/hs-pwstore-fast/Makefile
+++ b/security/hs-pwstore-fast/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pwstore-fast
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= security haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,7 +16,7 @@ COMMENT= Secure password storage
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= base64-bytestring>=0.1 cryptohash>=0.6
+USE_CABAL= base64-bytestring>=0.1 cryptohash>=0.6 random>=1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>