aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-12-10 05:26:06 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-12-10 05:26:06 +0800
commit21abc3a6e24958f73c479714d2785a3817562540 (patch)
treeabaac785ad7a059a97cc8030ce453b34c47bbd53 /security
parent181a756864fa33fa72e8dcbd4124ac36f01fc164 (diff)
downloadfreebsd-ports-gnome-21abc3a6e24958f73c479714d2785a3817562540.tar.gz
freebsd-ports-gnome-21abc3a6e24958f73c479714d2785a3817562540.tar.zst
freebsd-ports-gnome-21abc3a6e24958f73c479714d2785a3817562540.zip
This version of the port also requires devel/py-construct, www/py-requests,
devel/py-click and security/py-pyblake2 to run trezorctl. While here sort RUN_DEPENDS. MFH is not needed since this port was only recently updated after 2018Q4 was branched.
Diffstat (limited to 'security')
-rw-r--r--security/py-trezor/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/py-trezor/Makefile b/security/py-trezor/Makefile
index 553e275f6c9d..fcc52cfc0c2e 100644
--- a/security/py-trezor/Makefile
+++ b/security/py-trezor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= trezor
PORTVERSION= 0.11.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,10 +16,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= protoc:devel/protobuf \
${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}construct>=0:devel/py-construct@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyblake2>=0:security/py-pyblake2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
USES= python:3.3+ shebangfix
USE_PYTHON= autoplist concurrent distutils