aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-05-21 23:07:43 +0800
committerzi <zi@FreeBSD.org>2012-05-21 23:07:43 +0800
commit258deca1c95f61a1292826a9134184151ab4e849 (patch)
treec7d331c61919391aa721ed6416f7fcc89126b759 /security
parentb5cde3e4e1b82e7dcf958b9757d1ac5ed164a1a5 (diff)
downloadfreebsd-ports-gnome-258deca1c95f61a1292826a9134184151ab4e849.tar.gz
freebsd-ports-gnome-258deca1c95f61a1292826a9134184151ab4e849.tar.zst
freebsd-ports-gnome-258deca1c95f61a1292826a9134184151ab4e849.zip
New port: security/razorback-fileInject
Razorback is a framework for an intelligence driven security solution. It consists of a Dispatcher at the core of the system, surrounded by Nuggets of varying types. File Inject is a command-line file submission tool for the razorback framework. WWW: http://razorbacktm.sourceforge.net/ PR: ports/167746 Submitted by: Tom Judge <tom@tomjudge.com>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/razorback-fileInject/Makefile44
-rw-r--r--security/razorback-fileInject/distinfo2
-rw-r--r--security/razorback-fileInject/pkg-descr8
-rw-r--r--security/razorback-fileInject/pkg-plist6
5 files changed, 61 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c38a5d52d223..f552984a38a8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -783,6 +783,7 @@
SUBDIR += ratproxy
SUBDIR += rats
SUBDIR += razorback-api
+ SUBDIR += razorback-fileInject
SUBDIR += rdigest
SUBDIR += retranslator
SUBDIR += revelation
diff --git a/security/razorback-fileInject/Makefile b/security/razorback-fileInject/Makefile
new file mode 100644
index 000000000000..280d73c6d8ce
--- /dev/null
+++ b/security/razorback-fileInject/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: razorback-fileInject
+# Date created: 2011/06/8
+# Whom: Tom Judge <tom@tomjudge.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fileInject
+PORTVERSION= 0.5.0
+CATEGORIES= security
+MASTER_SITES= SF/razorbacktm/Nuggets
+PKGNAMEPREFIX= razorback-
+DIST_SUBDIR= razorback
+
+MAINTAINER= tom@tomjudge.com
+COMMENT= Framework for an intelligence driven security - File Injector
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
+
+OPTIONS= DEBUG "Enable Debug" off \
+ ASSERT "Enable Asserts" off
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+.if defined(WITH_ASSERT)
+CONFIGURE_ARGS+=--enable-assert
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/razorback/fileInject.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/razorback/fileInject.conf.sample ${PREFIX}/etc/razorback/fileInject.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/razorback-fileInject/distinfo b/security/razorback-fileInject/distinfo
new file mode 100644
index 000000000000..a2d2ab39bc79
--- /dev/null
+++ b/security/razorback-fileInject/distinfo
@@ -0,0 +1,2 @@
+SHA256 (razorback/fileInject-0.5.0.tar.gz) = aef94c80e3adf299f4a3f70c3d9ad796273bcddfab8f8e30308630c13e0da4c1
+SIZE (razorback/fileInject-0.5.0.tar.gz) = 315157
diff --git a/security/razorback-fileInject/pkg-descr b/security/razorback-fileInject/pkg-descr
new file mode 100644
index 000000000000..5c30a29f4a3e
--- /dev/null
+++ b/security/razorback-fileInject/pkg-descr
@@ -0,0 +1,8 @@
+Razorback is a framework for an intelligence driven security solution.
+It consists of a Dispatcher at the core of the system, surrounded by
+Nuggets of varying types.
+
+File Inject is a command-line file submission tool for the razorback
+framework.
+
+WWW: http://razorbacktm.sourceforge.net/
diff --git a/security/razorback-fileInject/pkg-plist b/security/razorback-fileInject/pkg-plist
new file mode 100644
index 000000000000..4f2075849811
--- /dev/null
+++ b/security/razorback-fileInject/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+bin/fileInject
+@unexec if cmp -s %D/etc/razorback/fileInject.conf %D/etc/razorback/fileInject.conf.sample; then rm -f %D/etc/razorback/fileInject.conf; fi
+etc/razorback/fileInject.conf.sample
+@exec if [ ! -f %D/etc/razorback/fileInject.conf ]; then cp -p %D/%F %B/fileInject.conf; fi
+@dirrmtry etc/razorback