aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-02-22 22:30:18 +0800
committermat <mat@FreeBSD.org>2018-02-22 22:30:18 +0800
commit2e03770e833c483c9928c7c01b3487ab51f431f8 (patch)
tree85ecd14b0f9e1bab042d6e64e97e8caac92e6c74 /security
parentccbcf9322355c25574c8e464aebdc23594b9607e (diff)
downloadfreebsd-ports-gnome-2e03770e833c483c9928c7c01b3487ab51f431f8.tar.gz
freebsd-ports-gnome-2e03770e833c483c9928c7c01b3487ab51f431f8.tar.zst
freebsd-ports-gnome-2e03770e833c483c9928c7c01b3487ab51f431f8.zip
Add py-certbot-dns-cloudflare, Cloudflare DNS Authenticator plugin for Certbot
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-certbot-dns-cloudflare/Makefile31
-rw-r--r--security/py-certbot-dns-cloudflare/distinfo3
-rw-r--r--security/py-certbot-dns-cloudflare/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ef3274f43158..8a58c8344bd3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -891,6 +891,7 @@
SUBDIR += py-cerealizer
SUBDIR += py-certbot
SUBDIR += py-certbot-apache
+ SUBDIR += py-certbot-dns-cloudflare
SUBDIR += py-certbot-nginx
SUBDIR += py-certifi
SUBDIR += py-cpe
diff --git a/security/py-certbot-dns-cloudflare/Makefile b/security/py-certbot-dns-cloudflare/Makefile
new file mode 100644
index 000000000000..abe4c3a2b7d4
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-cloudflare
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Cloudflare DNS plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cloudflare>=1.5.1:dns/py-cloudflare@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-cloudflare/distinfo b/security/py-certbot-dns-cloudflare/distinfo
new file mode 100644
index 000000000000..171cdd8be2ef
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518080463
+SHA256 (certbot-dns-cloudflare-0.21.1.tar.gz) = b284188339f24019312480829a7357ba2b932ded39aa7ff768e26d038a45a782
+SIZE (certbot-dns-cloudflare-0.21.1.tar.gz) = 12938
diff --git a/security/py-certbot-dns-cloudflare/pkg-descr b/security/py-certbot-dns-cloudflare/pkg-descr
new file mode 100644
index 000000000000..c0148d3f4c80
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/pkg-descr
@@ -0,0 +1,3 @@
+This is the Cloudflare DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot