aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-06-25 07:17:03 +0800
committerdinoex <dinoex@FreeBSD.org>2002-06-25 07:17:03 +0800
commit2edc2b6147f36f88b468a20944f50d369961f8b4 (patch)
tree2ce8e34290dae4b7d40e1d59aa0d98f4d1a36056 /security
parent115f1e63d639f04fe09fde74414446e6dcd20f5b (diff)
downloadfreebsd-ports-gnome-2edc2b6147f36f88b468a20944f50d369961f8b4.tar.gz
freebsd-ports-gnome-2edc2b6147f36f88b468a20944f50d369961f8b4.tar.zst
freebsd-ports-gnome-2edc2b6147f36f88b468a20944f50d369961f8b4.zip
Create user when package is extracted
Diffstat (limited to 'security')
-rw-r--r--security/hpn-ssh/pkg-plist3
-rw-r--r--security/openssh-portable/pkg-plist3
-rw-r--r--security/openssh/pkg-plist3
3 files changed, 9 insertions, 0 deletions
diff --git a/security/hpn-ssh/pkg-plist b/security/hpn-ssh/pkg-plist
index 4c71fad37b75..6069da804ff3 100644
--- a/security/hpn-ssh/pkg-plist
+++ b/security/hpn-ssh/pkg-plist
@@ -11,4 +11,7 @@ sbin/sshd
share/Ssh.bin
libexec/sftp-server
libexec/ssh-keysign
+@exec mkdir -p %D/empty
@dirrm empty
+@exec if ! pw groupshow sshd 2>/dev/null; then pw groupadd sshd -g 22; fi
+@exec if ! pw usershow sshd 2>/dev/null; then pw useradd sshd -g smmsp -u 22 -h - -d %D/empty -s /nonexistent -c "sshd privilege separation"; fi
diff --git a/security/openssh-portable/pkg-plist b/security/openssh-portable/pkg-plist
index 4c71fad37b75..6069da804ff3 100644
--- a/security/openssh-portable/pkg-plist
+++ b/security/openssh-portable/pkg-plist
@@ -11,4 +11,7 @@ sbin/sshd
share/Ssh.bin
libexec/sftp-server
libexec/ssh-keysign
+@exec mkdir -p %D/empty
@dirrm empty
+@exec if ! pw groupshow sshd 2>/dev/null; then pw groupadd sshd -g 22; fi
+@exec if ! pw usershow sshd 2>/dev/null; then pw useradd sshd -g smmsp -u 22 -h - -d %D/empty -s /nonexistent -c "sshd privilege separation"; fi
diff --git a/security/openssh/pkg-plist b/security/openssh/pkg-plist
index 49bdec074f00..977c6e9a8e86 100644
--- a/security/openssh/pkg-plist
+++ b/security/openssh/pkg-plist
@@ -33,3 +33,6 @@ libdata/ssh/Ssh.bin
@exec if [ ! -f %D/etc/ssh/ssh_host_key ]; then echo ">> Generating a secret RSA1 host key."; %D/bin/ssh-keygen -t rsa1 -N "" -f %D/etc/ssh/ssh_host_key; fi
@exec if [ ! -f %D/etc/ssh/ssh_host_rsa_key ]; then echo ">> Generating a secret RSA host key."; %D/bin/ssh-keygen -t rsa -N "" -f %D/etc/ssh/ssh_host_rsa_key; fi
@exec if [ ! -f %D/etc/ssh/ssh_host_dsa_key ]; then echo ">> Generating a secret DSA host key."; %D/bin/ssh-keygen -t dsa -N "" -f %D/etc/ssh/ssh_host_dsa_key; fi
+@dirrm empty
+@exec if ! pw groupshow sshd 2>/dev/null; then pw groupadd sshd -g 22; fi
+@exec if ! pw usershow sshd 2>/dev/null; then pw useradd sshd -g smmsp -u 22 -h - -d %D/empty -s /nonexistent -c "sshd privilege separation"; fi