aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2013-10-14 02:35:41 +0800
committerume <ume@FreeBSD.org>2013-10-14 02:35:41 +0800
commit39dd3005eea53a47b4bc24f9b926b40ced43cef1 (patch)
tree1f38ca92613b994e0438d8ede468651e352e9b3c /security
parent923d2051764c43bdc74e07d723d2dacf4208b596 (diff)
downloadfreebsd-ports-gnome-39dd3005eea53a47b4bc24f9b926b40ced43cef1.tar.gz
freebsd-ports-gnome-39dd3005eea53a47b4bc24f9b926b40ced43cef1.tar.zst
freebsd-ports-gnome-39dd3005eea53a47b4bc24f9b926b40ced43cef1.zip
use opt_USE knob.
Spotted by: sunpoet
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile4
-rw-r--r--security/cyrus-sasl2/Makefile22
2 files changed, 7 insertions, 19 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 080c3bbca853..3c3a861a3198 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -48,8 +48,10 @@ BDB_CONFIGURE_ON= --with-dblib=berkeley \
--with-bdb-libdir=${BDB_LIB_DIR} \
--with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb=${BDB_LIB_NAME}
+BDB_USE= BDB=yes
BDB_CONFIGURE_OFF= --with-dblib=ndbm
OPENLDAP_DESC= Use OpenLDAP
+OPENLDAP_USE= OPENLDAP=yes
OPENLDAP_CONFIGURE_ON= --with-ldap=${LOCALBASE}
HTTPFORM_DESC= Enable HTTP form authentication
HTTPFORM_CONFIGURE_ENABLE=httpform
@@ -57,7 +59,6 @@ HTTPFORM_CONFIGURE_ENABLE=httpform
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MBDB}
-USE_BDB= yes
INVALID_BDB_VER=2
.endif
@@ -65,7 +66,6 @@ INVALID_BDB_VER=2
.if defined(WITH_OPENLDAP_VER)
WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
-USE_OPENLDAP= yes
.endif
.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.so)
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index bb1e2687a688..547aafdc4847 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -54,18 +54,23 @@ KEEP_DB_OPEN_DESC= Keep handle to Berkeley DB open
KEEP_DB_OPEN_CONFIGURE_ENABLE=keep-db-open
OBSOLETE_CRAM_ATTR_DESC=cmusaslsecretCRAM-MD5 property
OBSOLETE_CRAM_ATTR_CONFIGURE_OFF=--enable-obsolete_cram_attr=no
+BDB_USE= BDB=yes
BDB_CONFIGURE_ON= --with-dblib=berkeley \
--with-bdb-libdir=${BDB_LIB_DIR} \
--with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb=${BDB_LIB_NAME}
BDB_CONFIGURE_OFF= --with-dblib=ndbm
+MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
MYSQL_CONFIGURE_OFF= --without-mysql
+PGSQL_USE= PGSQL=yes
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-pgsql
SQLITE2_DESC= SQLite 2 database
+SQLITE2_USE= SQLITE=2
SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE2_CONFIGURE_OFF= --without-sqlite
+SQLITE3_USE= SQLITE=3
SQLITE3_CONFIGURE_ON= --with-sqlite3=${LOCALBASE}
SQLITE3_CONFIGURE_OFF= --without-sqlite3
CRAM_DESC= CRAM-MD5 authentication
@@ -86,29 +91,12 @@ SCRAM_CONFIGURE_ENABLE= scram
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MBDB}
-USE_BDB= yes
INVALID_BDB_VER=2
SASLDB_NAME= sasldb2
.else
SASLDB_NAME= sasldb2.db
.endif
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE2}
-USE_SQLITE= 2
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE3}
-USE_SQLITE= 3
-.endif
-
.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || \
${PORT_OPTIONS:MSQLITE2} || ${PORT_OPTIONS:MSQLITE3}
CONFIGURE_ARGS+=--enable-sql