aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-22 20:40:04 +0800
committermat <mat@FreeBSD.org>2016-04-22 20:40:04 +0800
commit42e898d217fbdd36ab4d89ec0ce35514007e4985 (patch)
tree368b672d684456fd3d707cabe51d0c42518857db /security
parent5113c511dc0aee522032d69f0f95edfae18ceea7 (diff)
downloadfreebsd-ports-gnome-42e898d217fbdd36ab4d89ec0ce35514007e4985.tar.gz
freebsd-ports-gnome-42e898d217fbdd36ab4d89ec0ce35514007e4985.tar.zst
freebsd-ports-gnome-42e898d217fbdd36ab4d89ec0ce35514007e4985.zip
Move lang/go/files/bsd.go.mk to USES=go.
Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6057
Diffstat (limited to 'security')
-rw-r--r--security/go.crypto/Makefile6
-rw-r--r--security/goptlib/Makefile9
-rw-r--r--security/meek/Makefile9
-rw-r--r--security/pond/Makefile5
4 files changed, 8 insertions, 21 deletions
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
index c05314044774..052533a6f30e 100644
--- a/security/go.crypto/Makefile
+++ b/security/go.crypto/Makefile
@@ -8,6 +8,7 @@ MASTER_SITES= http://www.c-s.li/ports/
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Additional cryptography packages for Go
+USES= go
GO_PKGNAME= golang.org/x/crypto
GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/blowfish \
@@ -43,7 +44,4 @@ GO_TARGET= ${GO_PKGNAME}/bcrypt \
${GO_PKGNAME}/xtea \
${GO_PKGNAME}/xts
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/goptlib/Makefile b/security/goptlib/Makefile
index d787f3577ce2..375844b9b261 100644
--- a/security/goptlib/Makefile
+++ b/security/goptlib/Makefile
@@ -8,13 +8,8 @@ MASTER_SITES= http://c-s.li/ports/
MAINTAINER= cs@FreeBSD.org
COMMENT= Go pluggable transports library
+USES= go
GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
GO_TARGET= ${GO_PKGNAME}
-post-extract:
- @${MKDIR} ${GO_WRKSRC:H}
- @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/meek/Makefile b/security/meek/Makefile
index 4023efafa7a3..d3aafc881b35 100644
--- a/security/meek/Makefile
+++ b/security/meek/Makefile
@@ -10,20 +10,15 @@ COMMENT= Pluggable transport proxy that relays through third-party server
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/git.torproject.org/pluggable-transports/goptlib.git.a:security/goptlib
+USES= go
PLIST_FILES= bin/meek-client bin/meek-server man/man1/meek-client.1.gz man/man1/meek-server.1.gz
SUB_FILES= pkg-message
GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
GO_TARGET= ${GO_PKGNAME}/${PORTNAME}-server \
${GO_PKGNAME}/${PORTNAME}-client
-post-extract:
- @${MKDIR} ${GO_WRKSRC:H}
- @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/meek-server.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/meek-client.1 ${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pond/Makefile b/security/pond/Makefile
index 02f40eefff7a..8cc9cb444795 100644
--- a/security/pond/Makefile
+++ b/security/pond/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= tor:security/tor
LIB_DEPENDS= libgtkspell.so:textproc/gtkspell \
libtspi.so:security/trousers
+USES= go
PLIST_FILES= bin/pond-server bin/pond
USE_GNOME= gtk30
GO_PKGNAME= github.com/agl/pond
@@ -61,6 +62,4 @@ post-patch:
do-build:
@(cd ${GO_WRKSRC}; ${SETENV} ${GO_ENV} ${GO_CMD} install -tags nogui -v ${GO_TARGET})
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>