aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 07:33:57 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 07:33:57 +0800
commit474f5a8e1cfcbee8e3ad5fc9801f290f44bd8f60 (patch)
treeb27071fadef3825a8e258a50597b0ceb4c986b1d /security
parent9eab68a2f88327cfadc47f3dcfaa9d8e4d7faabd (diff)
downloadfreebsd-ports-gnome-474f5a8e1cfcbee8e3ad5fc9801f290f44bd8f60.tar.gz
freebsd-ports-gnome-474f5a8e1cfcbee8e3ad5fc9801f290f44bd8f60.tar.zst
freebsd-ports-gnome-474f5a8e1cfcbee8e3ad5fc9801f290f44bd8f60.zip
- Add port for shipping of PAM modules used by KDM.
It deprecates the "kde" module in base, and installs (optionally) the "kde-np" module, which enables auto-logins.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pam_kde/Makefile35
-rw-r--r--security/pam_kde/files/kde19
-rw-r--r--security/pam_kde/files/kde-np20
-rw-r--r--security/pam_kde/pkg-descr1
5 files changed, 76 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index fb2e5edf42c1..e13f4a973422 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -569,6 +569,7 @@
SUBDIR += pam_google_authenticator
SUBDIR += pam_helper
SUBDIR += pam_jail
+ SUBDIR += pam_kde
SUBDIR += pam_krb5
SUBDIR += pam_ldap
SUBDIR += pam_mkhomedir
diff --git a/security/pam_kde/Makefile b/security/pam_kde/Makefile
new file mode 100644
index 000000000000..aef8961c54c2
--- /dev/null
+++ b/security/pam_kde/Makefile
@@ -0,0 +1,35 @@
+# New ports collection Makefile for: pam_kde
+# Date created: 29 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_kde
+PORTVERSION= 1.0
+CATEGORIES= security kde
+MASTER_SITES= # empty
+DISTFILES= # none
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= PAM modules for KDE Display Manager
+
+NO_BUILD= yes
+
+PLIST_FILES= etc/pam.d/kde
+
+OPTIONS= AUTOLOGIN "Install module for automatic login" on
+
+.include <bsd.port.options.mk>
+
+.ifndef(WITHOUT_AUTOLOGIN)
+PLIST_FILES+= etc/pam.d/kde-np
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${FILESDIR}/kde ${PREFIX}/etc/pam.d
+.ifndef(WITHOUT_AUTOLOGIN)
+ ${INSTALL_DATA} ${FILESDIR}/kde-np ${PREFIX}/etc/pam.d
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pam_kde/files/kde b/security/pam_kde/files/kde
new file mode 100644
index 000000000000..f7d54f66c6ca
--- /dev/null
+++ b/security/pam_kde/files/kde
@@ -0,0 +1,19 @@
+#
+# $FreeBSD$
+#
+# PAM configuration for the "kde" service
+#
+
+# auth
+#auth sufficient pam_krb5.so no_warn try_first_pass
+#auth sufficient pam_ssh.so no_warn try_first_pass
+auth required pam_unix.so no_warn try_first_pass
+
+# account
+account required pam_nologin.so
+#account required pam_krb5.so
+account required pam_unix.so
+
+# session
+#session optional pam_ssh.so want_agent
+session required pam_permit.so
diff --git a/security/pam_kde/files/kde-np b/security/pam_kde/files/kde-np
new file mode 100644
index 000000000000..4cc5754850b7
--- /dev/null
+++ b/security/pam_kde/files/kde-np
@@ -0,0 +1,20 @@
+#
+# $FreeBSD$
+#
+# PAM configuration for the "kde-np" service
+#
+
+# auth
+#auth sufficient pam_krb5.so no_warn try_first_pass
+#auth sufficient pam_ssh.so no_warn try_first_pass
+#auth required pam_unix.so no_warn try_first_pass
+auth required pam_permit.so
+
+# account
+account required pam_nologin.so
+#account required pam_krb5.so
+account required pam_unix.so
+
+# session
+#session optional pam_ssh.so want_agent
+session required pam_permit.so
diff --git a/security/pam_kde/pkg-descr b/security/pam_kde/pkg-descr
new file mode 100644
index 000000000000..26a9ce45fecf
--- /dev/null
+++ b/security/pam_kde/pkg-descr
@@ -0,0 +1 @@
+This port installs PAM modules used by KDM to log into a KDE session.