aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorleres <leres@FreeBSD.org>2018-10-18 07:05:55 +0800
committerleres <leres@FreeBSD.org>2018-10-18 07:05:55 +0800
commit51bc61deeb0407a6ddef9b9690b70b9eee987793 (patch)
treefec64acdc4bcec57f313013baa95d1090056450f /security
parent046a475a19bdd488abc210694836059068faebe4 (diff)
downloadfreebsd-ports-gnome-51bc61deeb0407a6ddef9b9690b70b9eee987793.tar.gz
freebsd-ports-gnome-51bc61deeb0407a6ddef9b9690b70b9eee987793.tar.zst
freebsd-ports-gnome-51bc61deeb0407a6ddef9b9690b70b9eee987793.zip
Bro 2.5.5 does not build under 12.0-ALPHA10 due to openssl 1.1.1
in the base. Unbreak build by statically linking against security/openssl. This is a stopgap until Bro 2.6 which supports openssl 1.1 is released. It is currently in beta and due in a few weeks. Add missing NETMAP_DESC while we're here. Reviewed by: ler (mentor) Approved by: ler (mentor) Differential Revision: https://reviews.freebsd.org/D17602
Diffstat (limited to 'security')
-rw-r--r--security/bro/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index aa3c101c78d4..d9819793becf 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -63,6 +63,7 @@ BROKER_DESC= Enable the Broker communication library
IPSUMDUMP_DESC= Enables traffic summaries
LBL_CF_DESC= Unix time to formated time/date filter support
LBL_HF_DESC= Address to hostname filter support
+NETMAP_DESC= Native Netmap Packet IOSource for Bro
PERFTOOLS_DESC= Use Perftools to improve memory & CPU usage
BROCTL_IMPLIES= BROCCOLI IPSUMDUMP
@@ -140,4 +141,18 @@ post-build-NETMAP-on:
--install-root=${STAGEDIR}${PREFIX}/lib/bro/plugins && \
make && make install)
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000
+BUILD_DEPENDS+= ${NONEXISTENT}:security/openssl:stage
+CXXFLAGS+= -I${WRKDIR}/openssl/include
+OPENSSL_LDFLAGS+= -L${WRKDIR}/openssl/lib
+
+# Don't use COPYTREE_SHARE here as it hard links files, and the original files
+# are owned by root, which creates problems of its own.
+pre-configure:
+ @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/openssl`${PREFIX} \
+ && ${FIND} -E . ! -name *.so* | ${CPIO} -dump ${WRKDIR}/openssl >/dev/null 2>&1
+.endif
+
.include <bsd.port.mk>