aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-13 18:22:57 +0800
committerpat <pat@FreeBSD.org>2002-03-13 18:22:57 +0800
commit531b8fda9b07e29d6d47c6fc61346f54443e6dcf (patch)
tree3b573d10706ec1534e2ace3457c7e5d2c0d9adda /security
parent359096f39a893a6ad7bfe455ac5f6a3b0c25fdc6 (diff)
downloadfreebsd-ports-gnome-531b8fda9b07e29d6d47c6fc61346f54443e6dcf.tar.gz
freebsd-ports-gnome-531b8fda9b07e29d6d47c6fc61346f54443e6dcf.tar.zst
freebsd-ports-gnome-531b8fda9b07e29d6d47c6fc61346f54443e6dcf.zip
Fix installing translations to unbreak install
Noticed by: bento
Diffstat (limited to 'security')
-rw-r--r--security/fwlogwatch/Makefile13
-rw-r--r--security/fwlogwatch/files/patch-Makefile34
2 files changed, 38 insertions, 9 deletions
diff --git a/security/fwlogwatch/Makefile b/security/fwlogwatch/Makefile
index 160aec4a63d3..6140d70e355d 100644
--- a/security/fwlogwatch/Makefile
+++ b/security/fwlogwatch/Makefile
@@ -18,15 +18,14 @@ LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
INSTALL_TARGET= install install-config install-i18n
MANCOMPRESSES= no
MAN8= fwlogwatch.8
+MAKE_ENV= MKDIR="${MKDIR}"
post-patch:
- @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g ; \
- s,/etc,${PREFIX}/etc,g ; \
- s,/usr/local,${PREFIX},g ; \
- s,/usr/share,${PREFIX}/share,g" ${WRKSRC}/Makefile
- @${PERL} -pi -e "s,/etc,${PREFIX}/etc,g ; \
- s,/usr/share,${PREFIX}/share,g ; \
- s,/usr/local,${PREFIX},g" ${WRKSRC}/main.h
+ @${PERL} -pi -e 's,/etc,${PREFIX}/etc,g; \
+ s,/usr/local,${PREFIX},g; \
+ s,/usr/share,${PREFIX}/share,g; \
+ s,%%LOCALBASE%%,${LOCALBASE},g' \
+ ${WRKSRC}/Makefile ${WRKSRC}/main.h
@${PERL} -pi -e "s,/etc,${PREFIX}/etc,g" ${WRKSRC}/${MAN8}
post-install:
diff --git a/security/fwlogwatch/files/patch-Makefile b/security/fwlogwatch/files/patch-Makefile
index 114016ce0bb6..ce7ea4e47653 100644
--- a/security/fwlogwatch/files/patch-Makefile
+++ b/security/fwlogwatch/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Feb 24 20:15:21 2002
-+++ Makefile Fri Mar 8 23:42:07 2002
+--- Makefile.orig Sun Feb 24 07:15:21 2002
++++ Makefile Wed Mar 13 05:04:51 2002
@@ -1,10 +1,10 @@
# $Id: Makefile,v 1.56 2002/02/24 12:15:21 bw Exp $
@@ -26,3 +26,33 @@
# You might want to add -DSHORT_NAMES to CFLAGS if you only intend to
# analyze log formats with short list/chain/branch/interface names like
+@@ -35,10 +35,9 @@
+ LEX = flex
+ LFLAGS = -B #-f #-p -p -d
+
+-INSTALL = install
+-INSTALL_PROGRAM = $(INSTALL) -s -m 0755
+-INSTALL_SCRIPT = $(INSTALL) -m 0755
+-INSTALL_DATA = $(INSTALL) -m 0644
++INSTALL_PROGRAM= ${BSD_INSTALL_PROGRAM}
++INSTALL_DATA= ${BSD_INSTALL_DATA}
++INSTALL_SCRIPT= ${BSD_INSTALL_SCRIPT}
+
+ OBJS = cisco_ios.o cisco_pix.o compare.o ipchains.o ipfilter.o \
+ main.o modes.o net.o netfilter.o output.o parser.o \
+@@ -82,10 +81,15 @@
+
+ install-i18n:
+ cd po; make
++ ${MKDIR} ${PREFIX}/share/locale/de/LC_MESSAGES
+ $(INSTALL_DATA) po/de.mo /usr/share/locale/de/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} ${PREFIX}/share/locale/pt_BR/LC_MESSAGES
+ $(INSTALL_DATA) po/pt_BR.mo /usr/share/locale/pt_BR/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} ${PREFIX}/share/locale/sv/LC_MESSAGES
+ $(INSTALL_DATA) po/sv.mo /usr/share/locale/sv/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} ${PREFIX}/share/locale/zh_CN/LC_MESSAGES
+ $(INSTALL_DATA) po/zh_CN.mo /usr/share/locale/zh_CN/LC_MESSAGES/fwlogwatch.mo
++ ${MKDIR} ${PREFIX}/share/locale/zh_TW/LC_MESSAGES
+ $(INSTALL_DATA) po/zh_TW.mo /usr/share/locale/zh_TW/LC_MESSAGES/fwlogwatch.mo
+
+ uninstall: