aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-10-25 04:45:09 +0800
committerflo <flo@FreeBSD.org>2013-10-25 04:45:09 +0800
commit53606ea282935241d14b6163ceae03f85412fcb6 (patch)
treea5c901c8fde091b19740dcc7f096b49a3395196e /security
parente76f4eb44d44998e7c0a31bee05b494873579a7c (diff)
downloadfreebsd-ports-gnome-53606ea282935241d14b6163ceae03f85412fcb6.tar.gz
freebsd-ports-gnome-53606ea282935241d14b6163ceae03f85412fcb6.tar.zst
freebsd-ports-gnome-53606ea282935241d14b6163ceae03f85412fcb6.zip
- fix stage conversion in the ETCSYMLINK case
- move the check to post-install Reported by: ak
Diffstat (limited to 'security')
-rw-r--r--security/ca_root_nss/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/ca_root_nss/Makefile b/security/ca_root_nss/Makefile
index db4667ad0ba8..f0bf1ae5ba71 100644
--- a/security/ca_root_nss/Makefile
+++ b/security/ca_root_nss/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ca_root_nss
PORTVERSION= ${VERSION_NSS}
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= MOZILLA/security/nss/releases/${DISTNAME:U:C/[-.]/_/g}_RTM/src
DISTNAME= nss-${VERSION_NSS}${NSS_SUFFIX}
@@ -55,8 +56,11 @@ do-build: apply-slist
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${CERTDIR}
${INSTALL_DATA} ${WRKDIR}/ca-root-nss.crt ${STAGEDIR}${PREFIX}/${CERTDIR}
+
+post-install:
.if ${PORT_OPTIONS:METCSYMLINK}
- ${LN} -sf ${STAGEDIR}${PREFIX}/${CERTDIR}/ca-root-nss.crt /etc/ssl/cert.pem
+ ${MKDIR} ${STAGEDIR}/etc/ssl
+ ${LN} -sf ${PREFIX}/${CERTDIR}/ca-root-nss.crt ${STAGEDIR}/etc/ssl/cert.pem
.endif
.include <bsd.port.mk>