aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-08 06:29:46 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-08 06:29:46 +0800
commit6062703b809f64ef1da92cb001ceb2cd6e466e4c (patch)
tree9d553fcb5181a65656f17c284dc5954946973eb4 /security
parent92c5a7ac6b6df5b4df8a8ff50df634b053d9b450 (diff)
downloadfreebsd-ports-gnome-6062703b809f64ef1da92cb001ceb2cd6e466e4c.tar.gz
freebsd-ports-gnome-6062703b809f64ef1da92cb001ceb2cd6e466e4c.tar.zst
freebsd-ports-gnome-6062703b809f64ef1da92cb001ceb2cd6e466e4c.zip
Drop FreeBSD 10.3 support
Reviewed by: yuri (SoPlex), sunpoet (nghttp2), cpm (chromium), brooks (llvm*) Approved by: portmgr (rene) Differential Revision: https://reviews.freebsd.org/D15238
Diffstat (limited to 'security')
-rw-r--r--security/snort3/Makefile8
-rw-r--r--security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h14
2 files changed, 1 insertions, 21 deletions
diff --git a/security/snort3/Makefile b/security/snort3/Makefile
index 3ae531f5b2be..82532764f1c2 100644
--- a/security/snort3/Makefile
+++ b/security/snort3/Makefile
@@ -59,12 +59,6 @@ TSC_CMAKE_BOOL= ENABLE_TSC_CLOCK
# FLATBUFFERS_LIB_DEPENDS= libflatbuffers.so:devel/flatbuffers
HYPERSCAN_LIB_DEPENDS= libhs.so:devel/hyperscan
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1004000
-EXTRA_PATCHES= ${PATCHDIR}/freebsd103_patch-src_memory_memory__allocator.h
-.endif
-
CONFLICTS= snort-2*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h b/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h
deleted file mode 100644
index 82aa51523552..000000000000
--- a/security/snort3/files/freebsd103_patch-src_memory_memory__allocator.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/memory/memory_allocator.h.orig 2018-02-01 22:21:37 UTC
-+++ src/memory/memory_allocator.h
-@@ -34,4 +34,11 @@ struct MemoryAllocator
-
- } // namespace memory
-
-+// Fix for FreeBSD 10.3's broken toolchain
-+typedef struct {
-+ long long __max_align1 __aligned(_Alignof(long long));
-+ long double __max_align2 __aligned(_Alignof(long double));
-+} max_align_t;
-+
-+
- #endif