aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2014-04-19 04:28:52 +0800
committercs <cs@FreeBSD.org>2014-04-19 04:28:52 +0800
commit63dc53b959f8dd7f5d4aea39483bfd12e4eef4ed (patch)
tree885f9872b9f0ed33902e6dab6d1b2f737778bd84 /security
parent52384b44d06520cad4c6d10a3471a354201f8e10 (diff)
downloadfreebsd-ports-gnome-63dc53b959f8dd7f5d4aea39483bfd12e4eef4ed.tar.gz
freebsd-ports-gnome-63dc53b959f8dd7f5d4aea39483bfd12e4eef4ed.tar.zst
freebsd-ports-gnome-63dc53b959f8dd7f5d4aea39483bfd12e4eef4ed.zip
goptlib is a library for writing Tor pluggable transports in Go.
WWW: https://gitweb.torproject.org/pluggable-transports/goptlib.git
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/goptlib/Makefile20
-rw-r--r--security/goptlib/distinfo2
-rw-r--r--security/goptlib/pkg-descr3
-rw-r--r--security/goptlib/pkg-plist23
5 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9482811617b1..9f992de2fff2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -158,6 +158,7 @@
SUBDIR += gnutls
SUBDIR += gnutls3
SUBDIR += go.crypto
+ SUBDIR += goptlib
SUBDIR += gorilla
SUBDIR += gpa
SUBDIR += gpasman
diff --git a/security/goptlib/Makefile b/security/goptlib/Makefile
new file mode 100644
index 000000000000..615a0cca5055
--- /dev/null
+++ b/security/goptlib/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= goptlib
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= http://c-s.li/ports/
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Go pluggable transports library
+
+GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
+GO_TARGET= ${GO_PKGNAME}
+
+post-extract:
+ @${MKDIR} ${GO_WRKSRC:H}
+ @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/security/goptlib/distinfo b/security/goptlib/distinfo
new file mode 100644
index 000000000000..eb024ad9bf82
--- /dev/null
+++ b/security/goptlib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (goptlib-0.1.tar.gz) = 664ed228cc1cbd7b0dcd3fec896cc4bf7d33359c0289e368231fef108e1cf8c2
+SIZE (goptlib-0.1.tar.gz) = 19889
diff --git a/security/goptlib/pkg-descr b/security/goptlib/pkg-descr
new file mode 100644
index 000000000000..cb1a2db6b85a
--- /dev/null
+++ b/security/goptlib/pkg-descr
@@ -0,0 +1,3 @@
+goptlib is a library for writing Tor pluggable transports in Go.
+
+WWW: https://gitweb.torproject.org/pluggable-transports/goptlib.git
diff --git a/security/goptlib/pkg-plist b/security/goptlib/pkg-plist
new file mode 100644
index 000000000000..3140d7f94e35
--- /dev/null
+++ b/security/goptlib/pkg-plist
@@ -0,0 +1,23 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/COPYING
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/args.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/args_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/dummy-client/dummy-client.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/dummy-server/dummy-server.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pt.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pt_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/socks.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/socks_test.go
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/dummy-server
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/dummy-client
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%/examples
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/git.torproject.org/pluggable-transports
+@dirrmtry %%GO_SRCDIR%%/git.torproject.org
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry %%GO_LIBDIR%%/git.torproject.org/pluggable-transports
+@dirrmtry %%GO_LIBDIR%%/git.torproject.org
+@dirrmtry %%GO_LIBDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go