aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-03-31 00:36:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-03-31 00:36:59 +0800
commit6595e676862ecbee5430b2dbac3c7d5e5d3e3881 (patch)
tree60b9d772c06fd570e1ece1afb6c66f9423d718b9 /security
parent0f2309c7af7a05f361bef877e6acdc83af7d7081 (diff)
downloadfreebsd-ports-gnome-6595e676862ecbee5430b2dbac3c7d5e5d3e3881.tar.gz
freebsd-ports-gnome-6595e676862ecbee5430b2dbac3c7d5e5d3e3881.tar.zst
freebsd-ports-gnome-6595e676862ecbee5430b2dbac3c7d5e5d3e3881.zip
Fix rc.d script return value
PR: 145207 Submitted by: Dominic Fandrey <kamikaze@bsdforen.de>
Diffstat (limited to 'security')
-rw-r--r--security/vpnc/Makefile2
-rw-r--r--security/vpnc/files/vpnc.in5
2 files changed, 4 insertions, 3 deletions
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index c6a2df53a825..d2e3bccfd8f9 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
CRITICAL
diff --git a/security/vpnc/files/vpnc.in b/security/vpnc/files/vpnc.in
index 228374ac6529..7c02909915f0 100644
--- a/security/vpnc/files/vpnc.in
+++ b/security/vpnc/files/vpnc.in
@@ -44,8 +44,9 @@ vpnc_start() {
current="$vpnc_conf_dir/$config"
# Start vpnc.
- if ! $command --local-port 0 $current $vpnc_flags; then
- status=$?
+ $command --local-port 0 $current $vpnc_flags
+ status=$?
+ if [ $status -ne 0 ]; then
# VPNC does not print a newline after an error.
echo
echo "Running 'vpnc $current --local-port 0 $vpnc_flags' failed."