aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
committerbapt <bapt@FreeBSD.org>2012-05-31 19:19:32 +0800
commit68b530317704ed344f567080786046479ed054fb (patch)
tree93fe9eebc56e2451ba426603948adb8749cb38e9 /security
parentaedee365f6b7833ae31d4b673dcd979c369e4ac2 (diff)
downloadfreebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.gz
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.tar.zst
freebsd-ports-gnome-68b530317704ed344f567080786046479ed054fb.zip
Convert to new options framework
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-SASL/Makefile9
-rw-r--r--security/p5-Crypt-CBCeasy/Makefile33
-rw-r--r--security/p5-GD-SecurityImage/Makefile5
3 files changed, 26 insertions, 21 deletions
diff --git a/security/p5-Authen-SASL/Makefile b/security/p5-Authen-SASL/Makefile
index aca831df2c73..d500435fed55 100644
--- a/security/p5-Authen-SASL/Makefile
+++ b/security/p5-Authen-SASL/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl5 module for SASL authentication
RUN_DEPENDS= p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC
BUILD_DEPENDS= ${RUN_DEPENDS}
-OPTIONS= KERBEROS "Enable Kerberos support" On
+OPTIONS_DEFINE= KERBEROS
+OPTIONS_DEFAULT= KERBEROS
PERL_CONFIGURE= yes
CONFIGURE_ENV+= AUTOMATED_TESTING=yes
@@ -32,10 +33,10 @@ MAN3= Authen::SASL.3 \
Authen::SASL::Perl::LOGIN.3 \
Authen::SASL::Perl::PLAIN.3
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_KERBEROS)
+.if ${PORT_OPTIONS:MKERBEROS}
RUN_DEPENDS+= p5-GSSAPI>0:${PORTSDIR}/security/p5-GSSAPI
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-CBCeasy/Makefile b/security/p5-Crypt-CBCeasy/Makefile
index 598edc847ca2..107c28498edb 100644
--- a/security/p5-Crypt-CBCeasy/Makefile
+++ b/security/p5-Crypt-CBCeasy/Makefile
@@ -22,31 +22,34 @@ PERL_CONFIGURE= yes
MAN3= Crypt::CBCeasy.3
-.include <bsd.port.pre.mk>
-
-OPTIONS= DES "Build with Crypt::DES support" on
-.if !defined(WITHOUT_DES)
+OPTIONS_DEFINE= DES IDEA BLOWFISH BLOWFISH_PP TWOFISH2 RIJNDAEL
+OPTIONS_DEFAULT= DES IDEA BLOWFISH BLOWFISH_PP TWOFISH2 RIJNDAEL
+DES_DESC= Build with Crypt::DES support
+IDEA_DESC= Build with Crypt::IDEA support
+BLOWFISH_DESC= Build with Crypt::Blowfish support
+BLOWFISH_PP_DESC= Build with Crypt::Blowfish_PP support
+TWOFISH2_DESC= Build with Crypt::Twofish2 support
+RIJNDAEL_DESC= Build with Crypt::Rijndael support
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDES}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
.endif
-OPTIONS+= IDEA "Build with Crypt::IDEA support" on
-.if !defined(WITHOUT_IDEA)
+.if ${PORT_OPTIONS:MIDEA}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA
.endif
-OPTIONS+= BLOWFISH "Build with Crypt::Blowfish support" on
-.if !defined(WITHOUT_BLOWFISH)
+.if ${PORT_OPTIONS:MBLOWFISH}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
.endif
-OPTIONS+= BLOWFISH_PP "Build with Crypt::Blowfish_PP support" on
-.if !defined(WITHOUT_BLOWFISH_PP)
+.if ${PORT_OPTIONS:MBLOWFISH_PP}
BUILD_DEPENDS+= ${SITE_PERL}/Crypt/Blowfish_PP.pm:${PORTSDIR}/security/p5-Crypt-Blowfish_PP
.endif
-OPTIONS+= TWOFISH2 "Build with Crypt::Twofish2 support" on
-.if !defined(WITHOUT_TWOFISH2)
+.if ${PORT_OPTIONS:MTWOFISH2}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Twofish2.pm:${PORTSDIR}/security/p5-Crypt-Twofish2
.endif
-OPTIONS+= RIJNDAEL "Build with Crypt::Rijndael support" on
-.if !defined(WITHOUT_RIJNDAEL)
+.if ${PORT_OPTIONS:MRIJNDAEL}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Rijndael.pm:${PORTSDIR}/security/p5-Crypt-Rijndael
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-GD-SecurityImage/Makefile b/security/p5-GD-SecurityImage/Makefile
index b81e9e1e80b3..4b32798b22cb 100644
--- a/security/p5-GD-SecurityImage/Makefile
+++ b/security/p5-GD-SecurityImage/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl5 module for creating CAPTCHA security images
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
-OPTIONS= IMAGEMAGICK "Build ImageMagick module" off
+OPTIONS_DEFINE= IMAGEMAGICK
+IMAGEMAGICK_DESC= Build ImageMagick module
PORTSCOUT= skipv:1.581
@@ -31,7 +32,7 @@ MAN3= GD::SecurityImage.3 \
.include <bsd.port.options.mk>
-.if defined(WITH_IMAGEMAGICK)
+.if ${PORT_OPTIONS:MIMAGEMAGICK}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
.endif