aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2016-06-12 05:59:56 +0800
committercs <cs@FreeBSD.org>2016-06-12 05:59:56 +0800
commit6caabfad2c1843dee1c15cfb01538278ed5fcaa6 (patch)
treec69e44c7aa1c9be9e18a073a116c77346b241ddc /security
parentf8447b9056a47e0b7f8b50c8015e82094ea9e78f (diff)
downloadfreebsd-ports-gnome-6caabfad2c1843dee1c15cfb01538278ed5fcaa6.tar.gz
freebsd-ports-gnome-6caabfad2c1843dee1c15cfb01538278ed5fcaa6.tar.zst
freebsd-ports-gnome-6caabfad2c1843dee1c15cfb01538278ed5fcaa6.zip
This is a library for verifying YubiKey OTP tokens. It includes both the
low-level implementation for verifying tokens locally and clients for multiple versions of the Yubico validation web service. The primary audience is developers who wish to verify YubiKey tokens in their applications, presumably as part of a multi-factor authentication scheme. WWW: https://pypi.python.org/pypi/YubiOTP
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-YubiOTP/Makefile21
-rw-r--r--security/py-YubiOTP/distinfo3
-rw-r--r--security/py-YubiOTP/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 98ffd6bd6679..0436029d4e0c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -818,6 +818,7 @@
SUBDIR += py-Products.PluggableAuthService
SUBDIR += py-RestrictedPython
SUBDIR += py-SecretStorage
+ SUBDIR += py-YubiOTP
SUBDIR += py-acme
SUBDIR += py-acme-tiny
SUBDIR += py-artifacts
diff --git a/security/py-YubiOTP/Makefile b/security/py-YubiOTP/Makefile
new file mode 100644
index 000000000000..8d7c748bb1f9
--- /dev/null
+++ b/security/py-YubiOTP/Makefile
@@ -0,0 +1,21 @@
+# Created by: Carlo Strub <cs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= YubiOTP
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Library for verifying YubiKey OTP tokens
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-YubiOTP/distinfo b/security/py-YubiOTP/distinfo
new file mode 100644
index 000000000000..ece89135bbde
--- /dev/null
+++ b/security/py-YubiOTP/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1465681726
+SHA256 (YubiOTP-0.2.1.tar.gz) = 458b6db6e9988740766dc47ca5583ac4c4db8b7483ffa7e3bc82101e6b07075c
+SIZE (YubiOTP-0.2.1.tar.gz) = 17493
diff --git a/security/py-YubiOTP/pkg-descr b/security/py-YubiOTP/pkg-descr
new file mode 100644
index 000000000000..4fecf3a0031f
--- /dev/null
+++ b/security/py-YubiOTP/pkg-descr
@@ -0,0 +1,7 @@
+This is a library for verifying YubiKey OTP tokens. It includes both the
+low-level implementation for verifying tokens locally and clients for multiple
+versions of the Yubico validation web service. The primary audience is
+developers who wish to verify YubiKey tokens in their applications, presumably
+as part of a multi-factor authentication scheme.
+
+WWW: https://pypi.python.org/pypi/YubiOTP