aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-02 05:25:35 +0800
committerbapt <bapt@FreeBSD.org>2013-08-02 05:25:35 +0800
commit6db0408779037a64d9adb8b5267c94cd9e7414a5 (patch)
treeb309214cc07c24b2f49ba5bf27a51bd81e0693dd /security
parent7940fa7ac1eacfe9d23f99a3121292e8573d808e (diff)
downloadfreebsd-ports-gnome-6db0408779037a64d9adb8b5267c94cd9e7414a5.tar.gz
freebsd-ports-gnome-6db0408779037a64d9adb8b5267c94cd9e7414a5.tar.zst
freebsd-ports-gnome-6db0408779037a64d9adb8b5267c94cd9e7414a5.zip
Properly fix build with clang
Fix build without gcc
Diffstat (limited to 'security')
-rw-r--r--security/zxid/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index 66e247a6c3a1..f8ed1c58139a 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -18,7 +18,8 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -D_LSEEK_DECLARED -fPIC
MAKE_ARGS= CC="${CC}" CURL_ROOT="${LOCALBASE}" LD="${CC}" \
PREFIX="${PREFIX}" OPENSSL_ROOT="${OPENSSLBASE}"
-USE_GMAKE= yes
+USES= gmake
+USE_CSTD= gnu89
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -29,7 +30,7 @@ ZXID_BINS= smime zxcall zxcot zxdecode zxencdectest zxid zxidhlo \
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's/__inline//g' ${WRKSRC}/c/zx-attrs.c
+ @${REINPLACE_CMD} -e '/which gcc/d' ${WRKSRC}/Makefile
post-install:
${MKDIR} ${PREFIX}/include/zxid/