aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2007-10-17 18:13:01 +0800
committerade <ade@FreeBSD.org>2007-10-17 18:13:01 +0800
commit6f10a06995e640bf1073c28f5c13ea8f8412737a (patch)
treed14ccc864c4783b5751e425e681d4bc7e63ec159 /security
parent7428a469a6c4123272d6ac2707e3cf432227515b (diff)
downloadfreebsd-ports-gnome-6f10a06995e640bf1073c28f5c13ea8f8412737a.tar.gz
freebsd-ports-gnome-6f10a06995e640bf1073c28f5c13ea8f8412737a.tar.zst
freebsd-ports-gnome-6f10a06995e640bf1073c28f5c13ea8f8412737a.zip
Migration from bison 1.x to 2.x
PR: 117086 Tested by: -exp runs
Diffstat (limited to 'security')
-rw-r--r--security/aide/Makefile3
-rw-r--r--security/bro/Makefile4
-rw-r--r--security/nessus-libnasl/Makefile3
-rw-r--r--security/nessus-libraries/Makefile3
4 files changed, 8 insertions, 5 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index 40e426172382..7d662fecc3c0 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aide
PORTVERSION= 0.13.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.cs.tut.fi/~rammer/
@@ -20,7 +21,7 @@ LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
.include <bsd.port.pre.mk>
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
USE_AUTOTOOLS= autoconf:261
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-mhash \
diff --git a/security/bro/Makefile b/security/bro/Makefile
index f20c7f1cf720..f15c569bcadc 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bro
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://bro-ids.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-stable
@@ -14,13 +15,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-stable
MAINTAINER= pauls@utdallas.edu
COMMENT= System for detecting Network Intruders in real-time
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
-
OPTIONS= GPG "Support encrypted email" Off \
DOCS "Install documentation (not recommended)" Off
WRKSRC= ${WRKDIR}/bro-${PORTVERSION}.1
+USE_BISON= build
USE_LDCONFIG= ${PREFIX}/share
GNU_CONFIGURE= yes
MAKE_ENV+= CC="${CC}"
diff --git a/security/nessus-libnasl/Makefile b/security/nessus-libnasl/Makefile
index 80b4b5bb806f..401abeae6059 100644
--- a/security/nessus-libnasl/Makefile
+++ b/security/nessus-libnasl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nessus-libnasl
PORTVERSION= 2.2.9
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -24,7 +25,7 @@ DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/libnasl
USE_AUTOTOOLS= libtool:15
-USE_BISON= YES
+USE_BISON= build
GNU_CONFIGURE= yes
INSTALLS_SHLIB= YES
diff --git a/security/nessus-libraries/Makefile b/security/nessus-libraries/Makefile
index 302d983b55d7..8cd6c457ecc0 100644
--- a/security/nessus-libraries/Makefile
+++ b/security/nessus-libraries/Makefile
@@ -10,6 +10,7 @@
PORTNAME= nessus-libraries
PORTVERSION= 2.2.9
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.nessus.org/pub/nessus/nessus-${PORTVERSION}/src/ \
ftp://ftp.gwdg.de/pub/linux/misc/nessus/nessus-${PORTVERSION}/src/ \
@@ -24,7 +25,7 @@ COMMENT= Libraries for Nessus, the security scanner
DIST_SUBDIR= nessus
WRKSRC= ${WRKDIR}/nessus-libraries
-USE_BISON= YES
+USE_BISON= build
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-cipher
.if defined(WITH_NESSUS_BPF_SHARE)