aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcperciva <cperciva@FreeBSD.org>2015-08-26 00:41:01 +0800
committercperciva <cperciva@FreeBSD.org>2015-08-26 00:41:01 +0800
commit7810f41c46336a4dfc4b52c789bfd50119d97dc4 (patch)
tree023f4d8cebc7790929af1d7b8e90b5eefcf0b909 /security
parent9f09fa131020c273fb25f94d7d7379f1ceac93a1 (diff)
downloadfreebsd-ports-gnome-7810f41c46336a4dfc4b52c789bfd50119d97dc4.tar.gz
freebsd-ports-gnome-7810f41c46336a4dfc4b52c789bfd50119d97dc4.tar.zst
freebsd-ports-gnome-7810f41c46336a4dfc4b52c789bfd50119d97dc4.zip
Claim ownership of security/scrypt. It's my code anyway...
Remove SSE2 option; the latest version autodetects CPU support at runtime so it no longer has a compile-time selection. Remove USE_LDCONFIG; this port does not install any libraries, so it's not clear why this was ever in here.
Diffstat (limited to 'security')
-rw-r--r--security/scrypt/Makefile14
1 files changed, 1 insertions, 13 deletions
diff --git a/security/scrypt/Makefile b/security/scrypt/Makefile
index c35e6f9b3d27..7cd0cd8bb2a2 100644
--- a/security/scrypt/Makefile
+++ b/security/scrypt/Makefile
@@ -6,25 +6,13 @@ PORTVERSION= 1.2.0
CATEGORIES= security
MASTER_SITES= http://www.tarsnap.com/scrypt/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cperciva@tarsnap.com
COMMENT= Key Derivation Function
GNU_CONFIGURE= yes
USES= gmake tar:tgz
-USE_LDCONFIG= yes
PLIST_FILES= bin/scrypt \
man/man1/scrypt.1.gz
-OPTIONS_DEFINE= SSE2
-SSE2_DESC= Use SSE2-optimized code
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSSE2}
-CONFIGURE_ARGS+= --enable-sse2
-.else
-CONFIGURE_ARGS+= --disable-sse2
-.endif
-
.include <bsd.port.mk>